Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a returning Ubuntu user after a pause of a few years, so I have forgotten quite a bit.

My problem is that ALSA will not list my soundcard at all.. It cant find it. aplay command returns with: aplay: device_list:221: no soundcard found...

My hardware does recognize it tho:

:~$ lspci -v | grep -A7 -i "audio"

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
    Subsystem: Lenovo Device 38af
    Flags: bus master, fast devsel, latency 0, IRQ 11
    Memory at 9b100000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: snd-hda-intel


01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
    Subsystem: Lenovo Device 392d
    Flags: bus master, fast devsel, latency 0, IRQ 5
    Memory at 93000000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel modules: snd-hda-intel**

I've tried several things. This: https://help.ubuntu.com/community/SoundTroubleshooting

Updated kernel: My sound is not working in ubuntu 12.04

After that update, my system broke, so updated kernel to 3.5.0-45-generic

I guess you want the specs as well: http://www.lapspecs.com/detail/lenovo+g560 || It's the i5 430M'

Every time I boot up i get an error report on oss4-dkms:

DKMS make.log for oss4-4.2-build2005 for kernel 3.5.0-45-generic (i686)

cp: cannot stat`/lib/modules/3.5.0-45-generic/source/include/linux/limits.h': No such file or directory

I am out of ideas on how to fix this. Help is appreciated!

share|improve this question
    
I couldn't post another link, but here is the alsa-info-script link: alsa-project.org/db/?f=cce86dbbeccdcf0f207840427e7012d97312d8ab –  Colinde Jan 27 at 22:10

2 Answers 2

Installing OSS4 disables the kernel's built-in sound drivers. (And in your case, the bugs in OSS disable the OSS drivers.)

Uninstall OSS4.

share|improve this answer
    
I did.. Kept having problems. I did some digging last night after posting the problem, and found this brilliant update script for ALSA: stchman.com/alsa_update.html My sound works now, just not trough Flash plug-ins. But for some reason i still get that oss4 error, even though i was thorough with purging all oss4 packages. But thanks for the help. It's appreciated –  Colinde Jan 28 at 9:27

Problem resolved! I did some digging, and found a script to update the ALSA system. http://www.stchman.com/alsa_update.html Great script. I still get the oss4 error tho.. But the sound works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.