Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have a Lenovo Laptop (1TB, 4 GB RAM, AMD) running windows 8.1, and I've basically spent the past day trying to get Ubuntu dual-boot up-and-running on my laptop (I need it to run programs for school), but I seem to be remarkably adept at being stonewalled.

Here's a summary of the sweaty deathmatch with the computer to date:

I disabled quickstart and the UEFI secure boot thingy, and downloaded Ubuntu 13.10 (desktop amd x64) onto a 4 GB USB stick, using the universal USB installer 1.9.5.2. I partitioned 50 GB for it, which is now sitting unused. I restarted the computer holding F12, and then again mashing F12, and then all that again with F1, but for some reason I consistantly failed to bring up any special boot menu (if anybody's got anything on that, that would be much appreciated, although that's not the primary problem here).

So I found the advanced startup (inside PC settings), and I did that, and I was able to boot from my USB no problem ('run but don't install' option). It gave me the Ubuntu boot screen (purple fill with the ubuntu symbol and the four loading dots), and then cut to the black screen with the white text (you can tell that I know nothing about software) complaining about kernel problems. So I did it again, this time reformatting the USB drive and installing Ubuntu 12.04 with unetbootin.

When I restarted with the 12.04 USB, it told me that it was 'unable to find a medium containing a live file system', or something like that. So then I switched from the USB port 3.0 to the USB 2.0 and tried again. It did not show any error message, but it still dumped me in the same dark-bg-white-text screen with a command prompt, instead of any legible desktop. (as near as I can tell, this is the closest I've gotten to getting Ubuntu functional).

I tried disabling every mention of UEFI I could find in the troubleshooting menu (I had already gone in there previously to disable SafeStart), and restarting it in legacy mode But when I did that I got the 'unable to find medium' error, regardless of which USB port I used.

So I reverted to UEFI mode and tried a different tack; I downloaded Wubi, 18 GB. But I got this error message:

'NoneType' object has no attribute 'get_info'. For more information, please see the log file: c:\users\lukemacy\appdata\local\temp\wubi-12.04.3-rev.279.log

And I know that this bug is very similar to a known bug (if not the same bug entirely), which has had fixes posted by helpful users like yourselves. The problem is I have no idea what those fixes, with their technical jargon, meant. Also, the standard bug typically points to a different wubi file (26-something, as opposed to my 279), although I don't know whether that's important.

Anyway, that about sums up my day so far. I'm so inept! If anybody has noticed some way I'm ruining everything or just knows what to do, any help would be most appreciated! Except I have to ask that the explanation be in small words; I'm afraid I can't understand your mysterious technical sorcery language.

Thanks so much!

share|improve this question
    
Try burning a DVD following instructions from the Ubuntu.com site. I had some problems with USB booting on UEFI machines. LiveDVD does not appear to have these problems. –  user68186 Jan 27 at 21:30
    
If it's just for school, use a virtual machine (VMWare player or VirtualBox). If you don't need a GUI interface, you can get a free Amazon EC2 instance. You shouldn't need to disable secure boot or boot in legacy mode to run Ubuntu. –  bcbc Jan 28 at 0:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.