Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I VNC into my machine all I see is background image with no icons or unity or dash. I can't even right click on the desktop. The Unity launcher and Dash don't appear either.

This first happened a couple weeks ago and I tried a bunch of things like editing my Compiz settings, restarting lightdm etc. but none of them worked. Somehow, I did manage to get files on my desktop to show up, which made it easy for me to browse to other folders on the machine. Now, I can't even get that to appear.

Please let me know if there's a fix for this.

Update: Just noticed that this only occurs when I VNC into the machine. I have it plugged into a monitor now and everything appears to be normal.

Update 2: I just VNC into port 5900 (Ubuntu Remote Desktop) instead of using a TightVNCserver port (590x). Don't know why the tightvnc sessions couldn't get Unity or Dash to load. This is not really a fix but can hopefully help someone.

share|improve this question

1 Answer 1

What version are you running? I ran into the same problem and just switched to xrdp. This article is pretty straight forward: http://blogs.bu.edu/mhirsch/2013/12/xrdp-on-ubuntu-12-04/

...or this:

sudo apt-get update && sudo apt-get install xrdp

then

echo "gnome-session --session=ubuntu-2d" > /home/YOURUSER/.xsession

then

sudo /etc/init.d/xrdp restart

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.