Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup a VPN configuration file, the connection is responding but in order to actually connect to it I need to enable MSCHAP, MSCHAPv2 and MPPE, just like the picture here:

enter image description here

The problem arises when I need to do this from the terminal since I only have ssh access. I added this to my /etc/ppp/options.pptp:

refuse-pap
refuse-eap
refuse-chap
#refuse-mschap
require-mppe-128

When I try to dial the connection pon myvpn nodetach I get this response:

Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
MPPE required, but MS-CHAP[v2] auth not performed.
Connection terminated.

Any hint how to set this from terminal?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.