Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wifi is behaving strangely (not scanning, not connecting to networks) to remedy this I'm trying to install drivers from Intel. The device is an Intel Centrino Advanced-N 6205. The documentation wasn't very clear on how to install it. I downloaded the iwlwifi-6000g2a-6.ucode file from this Intel page, and copied that ucode file to /lib/firmware directory. That's all the documentation that came with the file told me to do. The information on this page is pretty much the same info I got with the ucode file from intel. There's some stuff about a firmware loader and kernel config file that I don't understand.

When I run $ sudo lshw -c network I find the following:

  *-network
   description: Wireless interface
   product: Centrino Advanced-N 6205 [Taylor Peak]
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 34
   serial: a0:88:b4:30:4b:08
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-35-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
   resources: irq:43 memory:c0500000-c0501fff

It looks to me that driverversion=3.8.0-35-generic means the kernel is using some generic Intel driver and not the one I just downloaded from Intel. Am I correct? and if so, how to I get the kernel to start using the new driver?

share|improve this question

1 Answer 1

You downloaded and installed firmware, not a driver. The driver, depending on the device ID, calls the firmware it requires. Your lshw shows that the driver is the usual kernel driver iwlwifi:

driver=iwlwifi

It also shows the firmware version being used:

firmware=18.168.6.1

Isn't that what you downloaded?

You might try the usual fix:

sudo -i
echo "options iwlwifi 11n_disable=1"  >>  /etc/modprobe.d/iwlwifi.conf
exit

Reboot and tell us if there is any improvement.

If you are still having trouble, let's look for clues in the logs. With the ethernet detached and a reboot so we have a clean slate, try to connect and then run:

cat /var/log/syslog | grep -e etwork -e wlan | tail -n25 > wifi.txt

Find the file wifi.txt in your user directory and paste the result here and give us the link in your reply: http://paste.ubuntu.com/

The firmware file you downloaded probably already existed in your system. Is yours the same as default?

md5sum /lib/firmware/iwlwifi-6000g2a-6.ucode

Mine reads 4b47db024c8a0cba872c3e98e907a378.

Sometimes, after hibernate, the driver doesn't reload. Try reloading it from the terminal:

sudo modprobe iwlwifi

You might try this fix:

gksudo gedit /etc/pm/config.d/config

Add one line:

SUSPEND_MODULES="iwlwifi"

Proofread carefully, save and close gedit. Reboot.

How does it work now?

share|improve this answer
    
Ok, so as you pointed out the firmware does look correct. I ran the commands you posted and gave it a reboot. The situation seems the same. I have to run sudo iwlist wlan0 scan just to get my router's SSID on the list. Then it just won't connect. It will try for a few minutes, ask me for the network key, try again, ask for key, and repeat this process until it gives up. Sometimes it will connect without hassle. Why it works 1 time out of 10, I haven't been able to figure out. –  PatMcTookis Jan 28 at 6:48
    
I belive I have found a weird work-around. If I hookup via ethernet, then run a wifi scan and connect, it almost always connects to the wifi on the first or second try. But once I reboot, it's back to the same nonsense. A bit of a hassle, plus I won't be able to hookup with ethernet at the library or cafe or wherever else I may go. –  PatMcTookis Jan 28 at 6:48
    
Please see my edit above. –  chili555 Jan 28 at 14:50
    
I get the same checksum: 4b47db024c8a0cba872c3e98e907a378 –  PatMcTookis Jan 28 at 16:26
    
Awesome. Now the paste, please. –  chili555 Jan 28 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.