Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I press the "Print Screen" the output captures both desktops instead of one!

This problem existed since I updated to Ubuntu 13.10.enter image description here

Update: I opened "Displays" from "System Settings", and found "Built-in Display" and "Unknown Display".

share|improve this question
    
Can you show a screenshot? –  Seth Jan 27 at 18:09

2 Answers 2

When you have multiple screens connected, I assume that print-screen usually captures both monitors at the same. It happens to me even now though I'm on a 12.04 (LTS).

You have number of options to over come this but of course not just limited to Print screen.

  • You may use ALT+ Print screen (this will only capture the current active window but not the entire screens itself)
  • You may also use Screenshot app from dash menu, hit super (WIN) key & select Grab the current window (will take the last active window) or Select area to grab (required area can be selected) else the other options as required
  • Use Shutter Install shutter, pretty advanced screenshot application that lets you do a lot more than just take screenshots - including choosing where to save them

Source: How can I print-screen just one window and not my entire desktop?

share|improve this answer
    
I have only one physical screen. I am using ubuntu on a laptop. What is being captured is to desktops. Sorry for the misleading title. –  Mohamed Ahmed Jan 28 at 0:58
    
I'm still not clear with your question yet. Could you please edit your question and add more details explaining a little more with screen shot if possible. –  AzkerM Jan 28 at 4:43
    
I have added a picture, this is the ouput of the Print Screen key. –  Mohamed Ahmed Jan 29 at 1:17
    
As your comment says that you've one physical screen but your image does seems that you've dual monitors connected (just an assumption). Pretty much confusing. –  AzkerM Jan 29 at 5:33
    
I have opened "Displays" from "System Settings". I found two displays, Built-in Display and Unknown Display! –  Mohamed Ahmed Feb 3 at 14:19
up vote 0 down vote accepted

In order to have the screenshot of one display, the "Unknown Display" should be turned off from the Display window which can be found in "System Settings".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.