Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded a java bin file manually from here. Then I tried to install it using the following commands. But I am not able to install it. Can anybody help me to install manually?

aneal@ubuntu:~/Downloads$ sh jdk-6u25-linux-i586.bin
Unpacking...
Checksumming...
Extracting...
jdk-6u25-linux-i586.bin: 113: ./install.sfx.5171: not found
Failed to extract the files.  Please refer to the Troubleshooting section of
the Installation Instructions on the download page for more information.


aneal@ubuntu:~/Downloads$ sudo ./jdk-6u25-linux-i586.bin
Unpacking...
Checksumming...
Extracting...
./jdk-6u25-linux-i586.bin: 113: ./install.sfx.5197: not found
Failed to extract the files.  Please refer to the Troubleshooting section of
the Installation Instructions on the download page for more information.

PS : My architecture is x86

share|improve this question

closed as too localized by Marco Ceppi Feb 3 '12 at 0:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
The installation file is for the x86 architecture - is your Ubuntu's architecture version also x86? –  htorque May 8 '11 at 7:05
    
Can you add the output of "uname -a" –  tgm4883 Jun 28 '11 at 3:29
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 3 '12 at 0:55

1 Answer 1

First, re-double-check that you are installing 32-bit Java on a 32-bit OS (or installing 64-bit Java on a 64-bit OS). While it's possible to install 32-bit Java on 64-bit Linux, usually there's no reason to (and you need to install extra dependencies to do it).

Second, clean up the old extracted files if the first installation attempt fails. Yo shouldn't have to "sudo" to install.

Third, don't try to "sh" the installer; instead, just make it executable (therefore you aren't relying on finding the right "sh" in your PATH):

$ chmod a+x ./jdk-6u25-linux-i586.bin
$ ./jdk-6u25-linux-i586.bin

Lastly, although you want to manually install the jdk.bin, you can first try to install the packaged JDK, to make sure you have all the dependencies. Depending on your version of Ubuntu, you might just be able to:

sudo apt-get update
sudo apt-get install sun-java6-jdk

You might have to add a ppa repository (pre-10.04) or enable "partner" repositories (10.04/10.10 or later). This has changed a bit from version to version (of ubuntu). (See: http://stackoverflow.com/questions/3747789/how-to-install-sun-jdk-on-ubuntu-10-10-maverick-meerkat )

share|improve this answer
    
tried already ! no luck !! –  nebula May 9 '11 at 10:26
    
maybe try a different version of Java and see if you get the same error, or at least more info on what the problem might be. Try java5, or java7 - see this question: askubuntu.com/questions/32124/… ... But if the "apt-get install sun-java6-jdk" worked, then consider it "job done"; there's no need to install the ".bin" manually anymore. If you want more than one jdk, just apt-get alternatives / galternatives. –  michael_n May 23 '11 at 22:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.