Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a left-handed thinkpad user and have grown used to using the trackpoint in its default right-handed configuration. When I use my bluetooth mouse, however, I would like the buttons to have a left-handed layout. In 11.04 (Natty) I can configure this manually using xinput, but I would like to have it applied automatically when the mouse is connected. I have followed the xorg documentation by creating /etc/X11/xorg.conf/99-ms500mouse.conf and placing the following into it:

Section "InputClass"
    Identifier "Microsoft Bluetooth Mouse 5000 button remap"
    MatchProduct "Microsoft Bluetooth Notebook Mouse 5000"
    MatchDevicePath "/dev/input/event*"
    Option "ButtonMapping"      "3 2 1 4 5 0 0 0 0 0 0 0"
EndSection

This seems to work initially (GDM seems to be using it correctly), but when I log in and start my X session, the buttons are mysteriously reverted:

$ xinput get-button-map "Microsoft Bluetooth Notebook Mouse 5000"

1 2 3 4 5 6 7 8 9 10 11 12

The following is my /var/log/Xorg.0.log:

[   276.648] (II) config/udev: Adding input device Microsoft Bluetooth Notebook Mouse 5000 (/dev/input/mouse1)
[   276.648] (II) No input driver/identifier specified (ignoring)
[   276.649] (II) config/udev: Adding input device Microsoft Bluetooth Notebook Mouse 5000 (/dev/input/event14)
[   276.649] (**) Microsoft Bluetooth Notebook Mouse 5000: Applying InputClass "evdev pointer catchall"
[   276.649] (**) Microsoft Bluetooth Notebook Mouse 5000: Applying InputClass "Microsoft Bluetooth Mouse 5000 button remap"
[   276.649] (II) Using input driver 'evdev' for 'Microsoft Bluetooth Notebook Mouse 5000'
[   276.649] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[   276.649] (**) Microsoft Bluetooth Notebook Mouse 5000: always reports core events
[   276.649] (**) Microsoft Bluetooth Notebook Mouse 5000: Device: "/dev/input/event14"
[   276.670] (**) Microsoft Bluetooth Notebook Mouse 5000: ButtonMapping '3 2 1 4 5 0 0 0 0 0 0 0'
[   276.670] (--) Microsoft Bluetooth Notebook Mouse 5000: Found 8 mouse buttons
[   276.670] (--) Microsoft Bluetooth Notebook Mouse 5000: Found scroll wheel(s)
[   276.670] (--) Microsoft Bluetooth Notebook Mouse 5000: Found relative axes
[   276.670] (--) Microsoft Bluetooth Notebook Mouse 5000: Found x and y relative axes
[   276.670] (--) Microsoft Bluetooth Notebook Mouse 5000: Found absolute axes
[   276.670] (II) evdev-grail: failed to open grail, no gesture support
[   276.670] (II) Microsoft Bluetooth Notebook Mouse 5000: Configuring as mouse
[   276.670] (II) Microsoft Bluetooth Notebook Mouse 5000: Adding scrollwheel support
[   276.670] (**) Microsoft Bluetooth Notebook Mouse 5000: YAxisMapping: buttons 4 and 5
[   276.670] (**) Microsoft Bluetooth Notebook Mouse 5000: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   276.670] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-2/4-2:1.0/bluetooth/hci0/hci0:11/input14/event14"
[   276.670] (II) XINPUT: Adding extended input device "Microsoft Bluetooth Notebook Mouse 5000" (type: MOUSE)
[   276.670] (II) Microsoft Bluetooth Notebook Mouse 5000: initialized for relative axes.
[   276.670] (WW) Microsoft Bluetooth Notebook Mouse 5000: ignoring absolute axes.
[   276.670] (**) Microsoft Bluetooth Notebook Mouse 5000: (accel) keeping acceleration scheme 1
[   276.670] (**) Microsoft Bluetooth Notebook Mouse 5000: (accel) acceleration profile 0
[   276.671] (**) Microsoft Bluetooth Notebook Mouse 5000: (accel) acceleration factor: 2.000
[   276.671] (**) Microsoft Bluetooth Notebook Mouse 5000: (accel) acceleration threshold: 4

As you can see, it appears to apply the button mapping I want (that is, swap buttons 3 and 1 and disable all others), but once the session starts this is gone. How do I make sure these settings stick?

Thanks a lot!

share|improve this question

1 Answer 1

Found the problem. gnome-settings-daemon is overriding the settings I give the mouse with the system-wide settings (which are set to right-handed). The only way to avoid this behavior is to fire up gconf-editor and find the key:

/apps/gnome_settings_daemon/plugins/mouse/active

And unset it. This will prevent it from overriding the settings specified in an xorg.conf (or fragment file in etc/X11/xorg.conf.d/).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.