Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm installing Ubuntu 13.04 (16 bit ) along with Windows 7 in my Lenovo Thinkpad. I was able to install Ubuntu successfully. But, after installation it asked me to restart now. I clicked on it. It started windows without showing boot menu. Now, what should I do to get the boot menu at the start.

This are the steps I tried and was not successful :
1. After browsing I found that boot repair has to be installed. I successfully used a Ubuntu live CD and tried to install the boot repair.
I tried the following commands -

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)  

But, I get this error now,

dpkg: error: reading package into file '/var/lib/dpkg/available' : Input/output error
E: subprocess /usr/bin/dpkg returned an error code (2)

how can I solve this problem to get a boot menu at the beginning.

share|improve this question
    
are you running both line of command at once? If not which one gives this error, line 1 or 2? If yes, enter one line at one time. –  Web-E Jan 27 at 10:56
    
@Web-E I'm entering one command at a time. –  Rudra Jan 27 at 10:59
    
So adding repo and apt list update is successfully done and then with 2nd line for installation this error is appearing ? –  Web-E Jan 27 at 11:06
    
@Web-E Yes I see this error in the second line –  Rudra Jan 27 at 11:08

1 Answer 1

If you are unable to install it from a live cd,I would recommend you to download an iso image file of boot-repair software and you can burn it to a cd or a usb using yumi or unetbootin

Here's the download link where you will get the iso image:

http://sourceforge.net/projects/boot-repair-cd/files/latest/download

For unetbootin for making a bootable usb:

http://sourceforge.net/projects/unetbootin/files/latest/download?source=directory

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.