Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to use my Virtual Box and this is the error I received - (I just updated to the new Ubuntu also) and I am VERY new at this Linux OS.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Virtualbox Kernel driver not installed

share|improve this question

21 Answers 21

Most probably all you have to do is run

sudo apt-get install dkms

(or install dkms from the software center)

and then run

sudo /etc/init.d/vboxdrv setup

and write your password.

share|improve this answer
vboxdrv doesn't exist. – weberc2 Jan 10 '13 at 23:01
@weberc2 VirtualBox OSE from Ubuntu repo doesn't have it, the version does have it. $ dpkg -S /etc/init.d/vboxdrv virtualbox-4.2: /etc/init.d/vboxdrv – gertvdijk Jan 10 '13 at 23:19
@gertvdijk gotcha. I'm going to try some of the other answers in this question first, but failing that I'll use the one from Why are so many of the apps in the Ubuntu repo are crippled when the generic versions are not? /rant – weberc2 Jan 10 '13 at 23:44
Too bad I have to run after every reboot :-/ Is there a more permanent solution? Or is this actually supposed to be permanent, and I have another problem? – Nicolas Raoul Aug 7 '15 at 2:41

Re-install virtualbox-dkms package first

sudo apt-get remove virtualbox-dkms
sudo apt-get install virtualbox-dkms

After that You can enable it manually

sudo modprobe vboxdrv
sudo modprobe vboxnetflt
share|improve this answer
sudo modprobe vboxnetflt results in FATAL: Module vboxnetflt not found. same for vboxdrv – weberc2 Jan 10 '13 at 23:38
Also, when installing virtualbox-dkms, I get non-error output like this: Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. – weberc2 Jan 10 '13 at 23:39
Thanks just doing this solved it for me: sudo apt-get remove virtualbox-dkms / sudo apt-get install virtualbox-dkms – David Sep 18 '13 at 20:15
On 13.10, with virtualbox-qt package installed this was the best solution for me, but with sudo apt-get install dkms virtualbox-dkms. Those packages installed the modules automatically, no other command was necessary. – Nathan Kidd Mar 8 '14 at 15:55
On 14.04 this also worked for me. It's important to make sure you install the headers for your kernel (see @Husni's answer) before reinstalling virtualbox-dkms, or the modules will not be built. – adelphus Mar 19 '15 at 16:17

here is solution which works for me on 12.10:

  1. Install the latest version of virtualbox according your architecture and distribution version from

  2. run sudo apt-get install build-essential linux-headers-`uname -r`

  3. run sudo /etc/init.d/vboxdrv setup

Last two steps quoted from one of the comments to the bug on the same theme -

share|improve this answer

On 12.10, these solutions all failed for me. However the following worked:

  1. Run command:

    sudo gedit /etc/apt/sources.list.d/vbox.list and paste in this line, then save:

    deb quantal contrib

  2. Run:

    sudo apt-get update && sudo apt-get -y upgrade to update your machine to the latest

  3. Run: sudo apt-get remove virtualbox* Then install Oracle's version:

    sudo apt-get install virtualbox-4.3

Should work now. Don't forget to download the extension pack from as well.

share|improve this answer
I'm running 12.10 64bit and this worked for me. – greg Apr 1 '13 at 6:59
13.04 and works! – asymptotically Jul 15 '13 at 18:09
14.04 - works fine. – 0x8BADF00D Oct 24 '14 at 1:31
14.10 - Worked for me, I just had to write deb trusty contrib instead. – Mahdi Jan 18 '15 at 14:46

In Ubuntu 14.04, 64 bit, what worked for me is

sudo dpkg-reconfigure virtualbox-dkms
share|improve this answer
This yeilds (for me): No suitable module for running kernel found. See Bug 1457776. – Lonnie Best Sep 22 '15 at 19:11
On 2015.04: dpkg-query: package 'virtualbox-dkms' is not installed and no information is available – Nicolas Raoul Nov 17 '15 at 5:08

I have the same issue and solved by these two steps:

sudo apt-get install linux-headers-`uname -r`


/etc/init.d/vboxdrv setup
share|improve this answer
On 2015.04: /etc/init.d/vboxdrv: No such file or directory – Nicolas Raoul Nov 17 '15 at 5:08

Did you install Virtualbox by downloading it from some web site?

If so, I'd recommend you to install it using the Ubuntu Software Center instead (type Virtualbox and click on install and you're set).

If you have some terminal skills, type this into the console:

sudo apt-get install virtualbox-ose

If you still want to do weird stuff to you computer/OS, then install the dependencies by hand: virtualbox-ose-dkms, libgl1-mesa-glx

share|improve this answer
Thanks, I have no terminal skills but am going to try and learn some :) and I did not install it, but am heading to try the software center. I was getting an error when I tried to update the new Virtualbox so maybe that will help also. I have the Oracle Virtualbox will go into it and see what it has... – Cyndi May 8 '11 at 20:35

Took me a long time to solve this issue. Had this problem with vBox across 2 distros (Ubuntu and Arch).

I had dkms and all the modules already installed and compiled into my kernel, yet I still got a module related error message when I tried to run a vBox virtual machine.

If your vBox GUI starts without a hitch but get an error telling to install the VBoxDrv kernel module when you try to run a virtual machine, your problems are not related to installing the modules into your kernel but ACTIVATING THEM in modprobe which the module installation script fails to do.

To load a module manually (such as vboxdrv in your case), open a terminal prompt and put in :

sudo modprobe vboxdrv

If you Virtual Machine runs after that without giving you an error message, then you can activate the vboxdrv module permanently by going to /etc/modules-load.d/ and making a .conf file (such as vbox.conf). In the .conf file the names of the vbox kernel modules you want to add, such as: vboxdrv.

Save and reboot

You can also ad these optional modules: vboxnetadp, vboxnetflt and vboxpci

From Vbox's wiki:

vboxnetadp and vboxnetflt are both needed when you intend to use the "Host-only networking" feature. More precisely, vboxnetadp is needed to create the host interface in the VirtualBox global preferences, and vboxnetflt is needed to launch a virtual machine using that network interface.

vboxpci is needed when your virtual machine needs to pass through a PCI device on your host.

Note: If the VirtualBox kernel modules were loaded in the kernel while you updated the modules, you need to reload them manually to use the new updated version. To do it, run vboxreload as root.

share|improve this answer
On 2015.04: modprobe: FATAL: Module vboxdrv not found – Nicolas Raoul Nov 17 '15 at 5:09

I found this works for me (quoted from forum):

sudo apt-get install dkms build-essential linux-headers-generic

If you want further granularity you can install the headers as such:

sudo apt-get install linux-headers-$(uname -r)

After this step reinstall the virtualbox related packages.

Some people in the forum said that only the second version worked for them.

share|improve this answer

I think Chriskin provided the answer, but you also want to make sure you have the proper Linux headers installed, as husni pointed out:

sudo apt-get install linux-headers-`uname -r`


sudo apt-get install dkms
sudo /etc/init.d/vboxdrv setup
share|improve this answer
This doesn't work. The /etc/init.d/vboxdrv file still doesn't exist. It was a nice try though. – weberc2 Jan 10 '13 at 23:47

I had exactly the same problem. My solution was to totally reinstall VirtualBox, with the following commands:

1) Delete (backup) the hidden VirutalBox directory in your home directory

mv ~/.VirtualBox ~/.VirtualBox-backup

2) Reinstall VirtualBox

sudo apt-get purge virtualbox
sudo apt-get install virtualbox

3) Run VirtualBox and set it (Virtual Images) up again.

share|improve this answer

This worked for me:

wget -O /tmp/virtualbox.patch ';filename=vbox-wheezy.patch;att=1;bug=696011'
cd /usr/src/virtualbox-4.1.12/
patch -p4 < /tmp/virtualbox.patch
dkms autoinstall
share|improve this answer

This question has answers already, This is to refer if some one else have and how I fix it. I also faced the same issue. My OS Ubuntu 14.04 and downloaded from the latest from (for my case 64 bit). I updated the linux headers.

 sudo apt-get install --reinstall linux-headers-$(uname -r)   

Then I reboot PC. That is all. :)

share|improve this answer

I had this problem in Kubuntu Vivid. I was struggling for a long time with the error "Your kernel headers for kernel 3.13.0-36-generic cannot be found.", and apt-get was unable to find it in the repositories.

The solution was to add a repository from trusty

deb trusty-security main 

to /etc/apt/sources.list, and install with

sudo apt-get install linux-headers-`uname -r 

and then run

sudo /etc/init.d/vboxdrv setup
share|improve this answer

I am using Ubuntu 14.04, I was having similar problem.My problem is solved by using below command for virtualbox installation:

sudo sh -c "echo 'deb '$(lsb_release -cs)' contrib non-free' > /etc/apt/sources.list.d/virtualbox.list" && wget -q -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install virtualbox-5.0

Actually it will remove your current version of Virtualbox and will install virtualbox-5.0 from the oracle maintained repository.

The above command is available at

share|improve this answer

i had this problem with Kubuntu 14.04.3 + virtualbox 4.3.10 from standard ubuntu trusty repository and none of previous solutions worked. the only solution was to add repository and upgrade to latest virtualbox (4.3.32). you can do that with this command:

sudo sh -c "echo 'deb '$(lsb_release -cs)' contrib non-free' > /etc/apt/sources.list.d/virtualbox.list" && wget -q -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install virtualbox-4.3
share|improve this answer
Did this answer not work? Invest some time in the site and you will gain sufficient privileges to upvote answers you like. – Martin Thornton Oct 31 '15 at 17:19

Not sure where else to drop this but for purposes of completeness: I had the same problem after an upgrade to 15.10. I tried everything mentioned in this post and others to no avail. My problem was that I kept missing hints that the root problem was with the kernel itself. It wasn't properly updated during the upgrade from 15.04 to 15.10. Mine was solved by Ubuntu kernel not updating with 15.10 which I then followed up with both of the "sudo dpkg-reconfigure" mentioned in answers here.

share|improve this answer

I have deb precise contrib in my /etc/apt/sources.list, to be able to use Virtualbox 5.x.

Faced with the same error, I tried all of the methods here and none work but this (bandwith-wasting) one:

  1. sudo apt-get purge virtualbox virtualbox-4* virtualbox-5*
  2. Reboot
  3. sudo apt-get install virtualbox-5.0
  4. Install the latest extension pack from
share|improve this answer

If I remember correctly I installed virtual-box using the .deb downloaded from the virtual box site, on 15.10. I fixed this problem by simply installing this package:

$ sudo apt-get install virtualbox-dkms
share|improve this answer

None of the answers mention simple solution which works for me.

sudo /usr/lib/virtualbox/ setup

I have Ubuntu 15.10 and Oracle VM 5.0.20. I've found the solution in vbox ticket.

share|improve this answer

I had this problem. I had virtual box 4.2

After upgrading to virtual box 4.3 the normal steps worked. Since my last ubuntu install was 'dirty' with trying all the advice I followed from this thread, it might be several things that worked, so please edit my answer if just updating vitualbox does the trick.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.