Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04.4 LTS with Xfce 4.10 on my Asus F5RL AP033C laptop. When I open nm-connection-editor from the notifications area (on it the "Enable Wireless" is in grey), in the Wireless tab there are no networks, same as with Wicd Network Manager. The WiFi LID on the laptop stays on all the time and I can't control it neither from Wicd nor by pressing Fn+F2. Firstly, I searched the Asus site for drivers, but there were no Linux ones. I tried adding to /etc/rc.local the line: echo 1 | tee /sys/devices/platform/asus_laptop/wlan because of those topics, I've found: 1, 2. One strange thing about those is that I changed the line, I was adding from asus-laptop to asus_laptop, because of the already existing folder. That wlan file contained 1 in it, so I edited it to become 0 and the LED turned off. I switched it back on, but I still couldn't see the list of available networks. I've also tried:

sudo apt-get purge --remove bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree
sudo modprobe b43

because of that topic, but without any effect. When I was searching the net for my laptop characteristics, I've found that my wireless is Integrated 802.11b/g.

sudo iwlist scanning returns:

wlan0     Interface doesn't support scanning : Network is down
lo        Interface doesn't support scanning.
eth0      Interface doesn't support scanning.

But there's an exception - when I first boot my laptop after being shut down it returns:

wlan0     No scan results
lo        Interface doesn't support scanning.
eth0      Interface doesn't support scanning.

sudo lshw -C network returns:

  *-network DISABLED      
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:6f:2f:ad
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=3.8.0-35-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:16 memory:fa9f0000-fa9fffff
  *-network
       description: Ethernet interface
       product: Attansic L2 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: a0
       serial: 00:1e:8c:73:14:d3
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl2 driverversion=2.2.3 duplex=full firmware=L2 ip=192.168.55.98 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:40 memory:feac0000-feafffff memory:feaa0000-feabffff

Unless when I just start my laptop, when it returns:

  *-network               
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:6f:2f:ad
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=3.8.0-35-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:16 memory:fa9f0000-fa9fffff
  *-network
       description: Ethernet interface
       product: Attansic L2 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: a0
       serial: 00:1e:8c:73:14:d3
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl2 driverversion=2.2.3 duplex=full firmware=L2 ip=192.168.55.98 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:40 memory:feac0000-feafffff memory:feaa0000-feabffff

lsusb returns:

Bus 001 Device 003: ID 0bda:0116 Realtek Semiconductor Corp. Mass Storage Device
Bus 001 Device 004: ID 174f:6a31 Syntek Web Cam - Asus A8J, F3S, F5R, VX2S, V1S
Bus 002 Device 002: ID 046d:c05b Logitech, Inc. M-U0004 810-001317 [B110 Optical USB Mouse]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

uname -a returns:

Linux qxp-F5RL 3.8.0-35-generic #50~precise1-Ubuntu SMP Wed Dec 4 17:28:45 UTC 2013 i686 i686 i386 GNU/Linux

dmesg | grep found returns:

[    0.000000] found SMP MP-table at [mem 0x000ff780-0x000ff78f] mapped at [c00ff780]
[    0.120335] ACPI: No dock devices found.
[    0.148019] pnp: PnP ACPI: found 10 devices
[    1.180113] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.180297] hub 1-0:1.0: USB hub found
[    1.240054] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    1.240210] hub 2-0:1.0: USB hub found
[    1.300053] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    1.300198] hub 3-0:1.0: USB hub found
[    1.360050] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[    1.360195] hub 4-0:1.0: USB hub found
[    1.420053] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
[    1.420204] hub 5-0:1.0: USB hub found
[    1.480054] usb usb6: New USB device found, idVendor=1d6b, idProduct=0001
[    1.480202] hub 6-0:1.0: USB hub found
[    1.515808] isapnp: No Plug & Play device found
[    1.518825] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[    1.700752] usb 1-4: New USB device found, idVendor=0bda, idProduct=0116
[    2.205672] usb 1-7: New USB device found, idVendor=174f, idProduct=6a31
[    2.639094] usb 2-1: New USB device found, idVendor=046d, idProduct=c05b
[   10.278986] lp: driver loaded but no devices found
[   13.667622] ath5k: phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)

dmesg | grep -i firmware returns nothing.

iwconfig returns:

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
lo        no wireless extensions.
eth0      no wireless extensions.

sudo lspci -nn has:

02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)

/var/log/udev has:

UDEV  [13.860291] add      /devices/pci0000:00/0000:00:04.0/0000:02:00.0/net/wlan0 (net)
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:04.0/0000:02:00.0/net/wlan0
DEVTYPE=wlan
ID_BUS=pci
ID_MM_CANDIDATE=1
ID_MODEL_FROM_DATABASE=AR242x / AR542x Wireless Network Adapter (PCI-Express)
ID_MODEL_ID=/sys/devices/pci0000:00/0000:00:04.0/0000:02:00.0
ID_VENDOR_FROM_DATABASE=Qualcomm Atheros
ID_VENDOR_ID=0x168c
IFINDEX=3
INTERFACE=wlan0
SEQNUM=1871
SUBSYSTEM=net
UDEV_LOG=3
USEC_INITIALIZED=13860052

It might have something to do with the result of sudo rfkill list all, which changes depending on whether I unplug the ethernet cable or whether I press Fn+F2. I explained exactly how in my comments on Olli's answer.

share|improve this question

2 Answers 2

I had same/similar problem with my computer, and after enabling wlan from /sys (setting wlan file contents to 1), solution appeared to be really trivial:

ifconfig wlan0 up
iwlist wlan0 scanning

Apparently iwlist returns Interface doesn't support scanning : Network is down if device is marked as down, even though device supports scanning.

share|improve this answer
    
ifconfig wlan0 up returns: SIOCSIFFLAGS: Operation not permitted and sudo ifconfig wlan0 up returns SIOCSIFFLAGS: Operation not possible due to RF-kill. After a bit of searching google, I've checked sudo rfkill list all and it returns 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes I've found topics, showing solutions to soft blocked, i.e. sudo rfkill unblock wifi; sudo rfkill unblock all but mine is hard blocked and I'm out of ideas what to do next. The "hardest" solution I could think of was pressing Fn+F2 without any effect. –  qxp Feb 4 at 21:16
    
I just tried sudo rm /dev/rfkill then I rebooted and tried sudo rfkill list all, which returned the same result. –  qxp Feb 4 at 21:58
    
I repeated the same process without being connected to internet by cable. The result was the same. –  qxp Feb 4 at 22:20
    
I don't know why, but today when I was turning on the laptop I tried sudo rfkill list all and none was blocked. I did sudo ifconfig wlan0 up which did its thing, because it didn't return an error. Then I did iwlist wlan0 scanning which showed wlan0 No scan results. I removed the cable and everything was just like yesterday - hard blocked: yes and the same errors from the other two commands. Plugging back the cable did nothing. –  qxp Feb 5 at 10:41
    
I've confirmed that when I start the laptop nothing is blocked, but when I unplug the cable the wifi gets hard blocked. Another strange thing, I found out is that when I press Fn+F2 the result first time is Soft blocked: yes Hard blocked: no then I continue pressing it and check for those results Soft blocked: no Hard blocked: yes, Soft blocked: yes Hard blocked: yes, Soft blocked: no Hard blocked: yes and so on it changes only the soft option. After all, I can get to a state, when both are unblocked (after a reboot) and in it, iwlist wlan0 scanning gives wlan0 No scan results. –  qxp Feb 5 at 22:32

If your Wireless is hard blocked try to enable it in BIOS

On first boot screen enter BIOS hit (F2 or F10 or F12 - depending on your BIOS configuration)

When in BIOS search for wireless to enable it if disabled (Most likely under configuration -> wireless -> enabled)

When enabled confirm and boot normally (probably F10)

Hope it helps.

This command bellow in your case wont do much since you run on atheros and not broadcom driver, so not really solving any issue in your case.

sudo apt-get purge --remove bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree
sudo modprobe b43

UPDATE Some Atheros drivers have issues with hardware encryption or decryption. Try this command bellow as root user

echo "options ath5k nohwcrypt=1" > /etc/modprobe.d/ath5k.conf

Reboot, see if finally works.

share|improve this answer
    
I've taken a look at my BIOS and the two options I tested to enable were Onboard LAN Boot ROM and Wake On LAN From System Off both of which had no effect on my problem. I didn't see anywhere else anything to do with network. –  qxp Feb 5 at 22:30
    
Well "enable wireless" option has to be somewhere there. Its usually located in some of configuration sub-menus under advanced or main menu depending on BIOS version. Hard block of wireless its almost always blocked in BIOS, especially if box come with Windows preloaded. Now based on your pics you checked power and boot sections which both have noting to do with wireless. –  danijelc Feb 6 at 11:33
    
Checked boxes in my house but I have different versions of BIOS and all offer configuration menu where wireless option is located –  danijelc Feb 6 at 12:21
    
I've searched through all the tabs the first time, I just didn't show them all to you. Here they are: Main, Advanced, Security, Power, Boot, Exit. Can you find the option, you're talking about from those images, or if you want me to, I'll take more? –  qxp Feb 8 at 7:58
    
I’m actually running off suggestions now, Could you try to check if under IDE configuration sub menu in advanced tab exists Onboard Devices Configuration or Onboard wireless menu or Onborad wlan? –  danijelc Feb 8 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.