Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use gedit-latex-plugin to edit my LaTeX documents. However, each time I open a .tex or .sty file, an annoying dialog labeled "Choose Master Document" pops up, and unless I select the same file again, gedit doesn't enter "LaTeX mode".

Is there a way to disable this dialog or simply always load "LaTeX mode" when a .tex file is opened?

share|improve this question
1  
It seems you must have a complete Latex document, that is, the \begin{document} and \end{document} statements are present. Whenever the \begin{document} statement is missing the plugin does this. –  Sabacon May 8 '11 at 0:58
    
I don't think that's it: it happens on complete, already compiled documents, and new ones alike. –  MarkovCh1 May 8 '11 at 2:38
    
This link may be heplful –  Eden Harder Apr 27 at 13:30

1 Answer 1

up vote 3 down vote accepted

The LaTeX plugin creates a hidden file .NAME.properties.xml (where NAME ist replaced by your .tex file's name) in the same folder as your .tex file. This file contains the settings for the master document, and if it's found the plugin doesn't ask for a master document.

A sample file looks like this:

<?xml version="1.0" ?><properties><property key="MasterFilename" value="my_master_document.tex"/></properties>

There doesn't seem to be a way to switch of this behaviour.

share|improve this answer
1  
What's weird is that it didn't used to be there... –  MarkovCh1 May 20 '11 at 7:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.