Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've upgraded 8 computers to 11.04 from 10.10 through the standard update version process. Two are giving me problems with the UDB optical mouse being frozen upon boot, to either a login prompt, or to the desktop.

Both computers are running AMD processors. Both are 32 bit systems. One has nVidia graphics and one has ATI graphics, which seems to rule out graphics. I tried changing the drivers on the nVidia system and that didn't make any difference. Doing a complete power down of the system was the only way I found try to get it working until I discovered that if I unplug the mouse mouse and plug it back in, it will work fine from then on. Doing a restart when it is frozen never results in a functioning mouse. Other than unplugging the mouse, a complete power down is required.

Both systems were using the same make/model of mouse, Logitech. To rule out it being the mouse, I've been using one of them on my laptop with 32 bit Ubuntu 11.04, and it has worked perfectly, so it most likely isn't a mouse issue, although using an Acer mouse on the one system seemed to alleviate the problem.

If I plug the Logitech mouse into the front mouse USB ports instead of using the rear USB ports on each computer, the number of times the mouse is frozen on boot has significantly been reduced. It still happens occasionally, but not nearly as frequently. Both computers are using PS2 keyboards, so I don't know the situation would be if they were USB.

The computer with the ATI graphics card is my wifes. I have the exact same computer at home with nVidia graphics at home. Mine has worked perfectly. But the other computer with problems has nVidia graphics, so, as I said before, I doubt it is a graphics problem.

I'm guessing it is a kernel issue.

One suggestion I found on line was modifying the grub file line



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=off" 

but that didn't make any difference. Both machines worked fine in 10.10, 10.04, 9.10, and 9.04.

It has now been two weeks since the last update here. My co-worker purchased a new Logitech wireless mouse. There have not been any freezes on boot with the wireless sending unit on either a front or rear USB port. On my wife's computer about 20% of the time her mouse is frozen on boot, but unplugging it and replugging it makes it work without issue.

share|improve this question
Please try this: When the PC starts press ESC like crazy until the GRUB menu appears. Press E on the option you would like to use then go to the line that loads the kernel and press E again. This time, go to the end of the file and REMOVE the quiet splash options. Press ENTER and then press B to boot. It will load everything the same except that now you will see what is happening. Maybe this will give you an inside into what is happening. Now i have a question apart from the above. Is this PC different than the rest. Motherboard, Video, Mouse, Bios Configuration? – Luis Alvarado May 8 '11 at 0:12
Thank you for your suggestion. I will not be able to try that until Monday now. The computers vary in age from 6 months old to 6 years old. All are HP's, Compaqs, or Acers, with nothing special about them. Almost all of them have AMD processors. There is a mix of video, motherboards, etc. These all belong to family, friends, and co-workers. There are about 14 which have not been upgraded yet. – Tractor May 8 '11 at 0:28
Try to find one or two that are very similar and compare Bios options, hardware similarities and such. That will gives us an idea on how to focus the help – Luis Alvarado May 8 '11 at 0:57
Thank you again for the additional help. Something I could also try is to set the boot to require the password, since the mouse is loaded before that window. When I am watching what is happening, is there something in particular that I should be watching for? – Tractor May 8 '11 at 3:06
Something in the lines of 'Mouse at USB just kicked the bucket...RIP' or in general any error about mouse. If you can load into terminal (Recovery Mode) instead of normal mode type dmesg to see all the stuff that happen while loading or a cat /var/log/syslog to see more stuff about it. Am sure something will appear. Thats about it from here to Monday you have much to test and look. Good luck buddy. – Luis Alvarado May 8 '11 at 8:06

I believe you might have this bug

the solution would be to install kernel 2.6.34

you can find it here

I'm not sure if this is the case, since the bug appeared with 10.10 but, it's worth to try.

share|improve this answer

I just started universal access and turned the screen reader on and then off again. No more problems with the mouse. I don't know why this works- it just does! Hardware Acer Aspire One Netbook AOA 150 Ab. I am a newby and think that the latest Ubuntu is a real contender in the o.s. stakes. If only the developers could make it easy to install a printer and scanner it took me hours.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.