Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After following all the guides, I've managed to configure juju in the local environment inside a virtualbox guest machine, but after deploying any service (wordpress,juju-gui), they load to the point where I get a local IP address, but they get stuck in pending status. When I check the logs, It shows this error in every service :

ERROR juju runner.go:211 worker: exited "uniter": ModeInstalling {service-name}:git init failed: exec: "git": executable file not found in $PATH.

I tried to apt-get git but it didn't work...

Updated Info :

The host OS is OS X Mavericks, VirtualBox is 4.3.6 using bridged networking, Ubuntu is the latest Ubuntu Cloud 13.10. In order to install everything, first I had to add more repositories to the system (universe,multiverse,etc.), then I did an apt-get juju-local, afterwards I had to create a new bridge in order to add my local ethernet interface to the lxc container (replaced lxcbr0 with br0) and configure lxc and the juju local config to use it. Then I bootstraped, deployed and exposed a couple of services( juju-gui, wordpress) and now I'm stuck in the situation with the error. I´ve pinged my host machine and external ip and I get connectivity, so I assume that´s not the issue.

Update II : Doing more tests I found out the error is that the containers don't have internet connection, I can ping the host but not the router or any other node in the network, thus while trying to download the dependecies, in this case git, they fail to load. So the question would be how to setup lxc containers with virtualbox bridge network connection. It's similar to this but I can ping the laptop and I'm using a briged network instead of NAT

share|improve this question
Can you expand your question a bit, what's the host OS, what version of virtual box, what version of Ubuntu in the vm, how did you install Juju, etc. – hatch Jan 26 '14 at 17:12
Can you explain in more detail why you did this: "...I had to create a new bridge in order to add my local ethernet interface to the lxc container (replaced lxcbr0 with br0) and configure lxc and the juju local config to use it." It seems like you're changing the way LXC subsystem works and then you expect juju to use your changes. It's not clear though what where you trying to accomplish by doing it. Have you tried following the documentation ( It should work just as well in a virtualbox VM, you won't even need to tweak the network setup. – dimitern Jan 27 '14 at 11:59
I did it in order to access the VM from outside, following this guide : – Axel Martinez Jan 27 '14 at 13:30
It is necessary in order to access the services outside of the VM, as I mentioned, I do have connectivity between host and the services, I can ping them, but then this error shows up... – Axel Martinez Jan 27 '14 at 13:36
Thanks for pointing out that question. I added a comment there about changing the "network-bridge" setting in environments.yaml to "br0" (the same you put in Try that and see if it will solve your issue. – dimitern Jan 30 '14 at 17:44

I think what I'm trying to do it´s impossible because of how VirtualBox implements bridge networking, here is a post I found that comments on this :

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.