Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There is a calendar on my desktop, I don't know how it got there, what it is or how to remove it.

It's seen in the upper left corner in this screen shot: http://i.imgur.com/rQF13dV.png

Any help on what it is or how to remove it would really be appreciated!

share|improve this question
add comment

3 Answers 3

I had the same problem with Linux Mint. Calendar just appeared and could not remove it like other desktop widgets. Obviously, it'd clicked something, somewhere to add this but have no-idea what it was.

I managed to get rid of it by right-clicking the desktop and selecting: "Folder Settings". I then changed the view layout from, "Folder" to "Default Desktop" and then clicking apply.

I was then able switch back to "Folder" as my view layout and whatever settings had created the calendar had been wiped.

Sorry, this does seem like a hack but it worked for me. I am sure there is a setting somewhere that just removes it but like you I was unable to find it.

share|improve this answer
1  
Not sure why I have been voted down on this answer but would be helpful if someone could leave a comment for me to explain. Obviously, I am not looking to give answers that are considered unhelpful, so some guidance would be great. The answer I gave was genuine and given in good faith. –  Stephen Simpson Mar 6 at 9:17
    
Your answer regarding switching "something" inspired me to try switching things while perusing system settings. I've added a trick that worked for me. –  Brady Trainor May 19 at 23:34
add comment

This is from the userbase.kde.org website

How do I remove widgets?

If they're on the panel, right click on the widget and select Remove this.... If the widgets are on the desktop, you have different options:

If you hover over them, clicking the X on the applet handle will remove them; If you use the Add Widget dialog, you can click on the minus symbol icon next to the widget name to remove it.

There is also some more info in relation to widgets on this page.

You may also find it useful to look at the general widget settings. Plasma Settings

To see the widgets that are installed on your system and ready to use open the Plasma Widget Explorer by either opening the Desktop Toolbox in the upper right corner of the screen and selecting Add Widgets, opening the Panel Toolbox furthest to the right in the Panel and selecting Add Widgets, or right clicking on the Desktop and choosing Add Widgets from the context menu. To place a widget on the Desktop simply drag it from the Widget Explorer to the Desktop. To place a widget in the panel first open the Panel Toolbox and from there open the Widget Explorer (click Add Widgets), locate the widget you wish to add and drag it to the desired position in the Panel.

Finally this is a link from the Ubuntu help pages. CustomizeKubuntu Please look at the section in relation to styles where it states;

A widget style is a plugin or a small program that instructs KDE how widgets are displayed.

Hope this helps.

share|improve this answer
1  
Thanks @qman. However, if the original poster had the same problem as me, there was no 'X' to remove the applet as there normally is. This may be some weird but, not sure but the Calendar was not behaving like a normal widget. –  Stephen Simpson Mar 3 at 12:34
1  
I saw mention in your links of "quit" plasma or something, restart, which seems promising but I found another hacky method first which I added, but just thought I'd mention it for the next troubleshooter that comes along. –  Brady Trainor May 19 at 23:44
add comment

Hacky solution that worked for me, similar issue, calendar stuck to Kubuntu desktop with no "x" to delete widget.

Went to System Settings, to group Workspace Appearance and Behavior, select Workspace Behavior, select Workspace, switch Workspace Type to Netbook, wait a moment for screen to change, then switch back to Desktop.

After this switch back and forth, the calendar stuck to my desktop was gone! :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.