Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Microsoft Lifecam NX-3000 that was working perfectly fine for skype yesterday and so far today skype won't even recognize that I have a camera plugged in.. I tried checking it in cheese too so it's not just skype. Any help would be greatly appreciated.

lsusb shows I have my camera plugged in and I have tried the following inputs so far:

sudo apt-get install libv4l-0 and the camera still was not working

and sudo modprobe v4l1_compat gave me FATAL: Module v4l1_compat not found.

share|improve this question
    
Try running cheese from the commandline. Do you get any errors? –  Seth Jan 26 at 4:19
    
The only error it shows is 'No device found' –  driftmonkey Jan 26 at 4:26
    
What is the output of cat /etc/modprobe.d/blacklist.conf and lsusb? –  Seth Jan 26 at 4:30
    
lsusb gives - Bus 001 Device 002: ID 045e:0721 Microsoft Corp. LifeCam NX-3000 (UVC-compliant) and I don't really know what to look for when I put cat /etc/modprobe.d/blacklist.conf I don't see anything about the camera though –  driftmonkey Jan 26 at 4:35
    
Does the cat command give lots of output? If so, add | grep uvcvideo to the end of the command and then run it. You don't want any output in this case. –  Seth Jan 26 at 4:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.