Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently upgraded from 10.10 to 11.04, and immediately switched to unity-2d (running on a netbook). Then I tried to load the 10.10 panels because I didn't like the globalmenu. After rebooting I ended up w/out Unity and w/out Gnome. Alt+F2 doesn't open terminal either, and I can only access the browser thanks to a keyboard shortcut I once set up. How do I resolve this mess..? When I logout/login it doesn't let me choose between settings (ubuntu classic, etc.).

Thanks!

share|improve this question
    
Boot into the recovery mode, choose Drop to root shell prompt, then do nano /home/YOURUSER/.dmrc and change the Session entry to Session=gnome-2d. Press Ctrl + o, Enter, Ctrl + x. Now run chown YOURUSER:YOURUSER /home/YOURUSER/.dmrc and reboot. You now should at least boot into a classic GNOME session. –  htorque May 7 '11 at 21:17
add comment

1 Answer 1

While not necessarily a solution to your dilemma, ATL-F2 should let you run anything. Does CTRL-ALT-T bring up a terminal window for you? Are you trying to run Unity with the addition of a Gnome-Panel at the bottom, or are you attempting to run the classic Gnome interface on your netbook?

share|improve this answer
    
htorque: I'm totally new to all of this. How do I book into the recovery mode, and where would I choose "drop to shell prompt"? Sorry, but it's getting a bit confusing from that point on.... Kory Wnuk: cntrl+alt+t doesn't work either. And I don't care much for unity any more ... I'd be happy with a simple classic Gnome interface. also, I'd like to add that the symptoms are similar to those reported here: askubuntu.com/questions/40426/… although I couldn't figure out if any answer there provides a solution –  Frustrated user May 7 '11 at 22:06
    
the answere here: askubuntu.com/questions/40426/… solved the problem. at least temporarily. Thanks. –  Frustrated user May 8 '11 at 9:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.