Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried to install gnome3 about 4 times and each time the same thing happens.

The computer screen goes black and nothing happens, and after I force restart the computer it boots up with the gnome screen but the mouse icon is gone.

Then I'm forced to boot up with a USB drive and reinstall Ubuntu.

I'm on 13.10

I used this method Install Gnome 3.10 in Ubuntu 13.10 without breaking Unity

but after the very last step there are no error messages or anything but the screen just goes black.

share|improve this question

closed as off-topic by Braiam, Olli, Ask, Avinash Raj, mikewhatever Feb 14 at 11:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Olli, Ask, Avinash Raj, mikewhatever
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is there some reason you want to be so adventurous? Could you not have just tried: sudo apt-get install gnome-shell gnome-shell-extensions, without also adding in 'dev.' PPAs. –  david6 Jan 26 at 2:15
    
Crashing after installing development stage apps is natural, you should report this upstream. –  Braiam Feb 13 at 2:17

3 Answers 3

I tried GNOME 3.10 in the late dev build of Trusty. It may seem to crash because its very buggy because of the merge in GNOME that allows you to have buttons and stuff on the very top of the title bar and Ubuntu doesn't support it very well it does but it looks very messy and glitchy and seems to crash Unity alot (Especially the login manager). My advice is to stick with 3.8 as that is the most stable version of GNOME available in Ubuntu currently

share|improve this answer

You can undo your changes (and go back to 3.8 on 13.10) with a handy tool named ppa-purge. First, you'll need to start on a tty, whether with the "recovery" entry in Grub, or by pressing Ctrl+Alt+F1 and loggin in when the system is running.

Install ppa-purge :

sudo apt-get install ppa-purge

Remove the Gnome3 ppa's and rollback your packages :

sudo ppa-purge ppa:gnome3-team/gnome3-next
sudo ppa-purge ppa:gnome3-team/gnome3-staging

Reboot. You are now on Gnome 3.8 for Unity !

Next time you want to try Gnome3 packages (I strongly recommend you not to, it's buggy with Unity), try instead this : sudo add-apt-repository ppa:gnome3-team/gnome3 && sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

share|improve this answer

can you write in terminal on this black screen? try type : startx or press CTRL+ALT+F1 and then write startx

share|improve this answer
    
I will try again and report back, I'm at the point where I can try as many times as needed because i already wiped everything from the ubuntu partition. –  michael fujimori Jan 25 at 19:26
    
I could not open a terminal in the black screen so i just force restarted it again and had the same problem with the missing mouse. I fixed it by using this command: "gsettings set org.gnome.settings-daemon.plugins.cursor active false" –  michael fujimori Jan 25 at 19:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.