Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can't for the life of me figure out how to get Ctrl-c to work. There are other programs I can't exit out of, but the one that bothers me the most tail -f filename. So what I tried to do to get out of this, I have tried Ctrl C, Ctrl Z, Ctrl D, Ctrl \, Ctrl-Shift C, Ctrl G

stty -a looks like this:

speed 38400 baud; rows 22; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = M-^?; eol2 = M-^?;
swtch = M-^?; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc ixany imaxbel iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke

I have tried changing the assignment of intr to a different key, but that didn't work either.

From my understanding, it is the job of the shell to transmit the intr to the program that is running.

share|improve this question
    
What shell and what virtual terminal are you using? –  Grimtech Jan 25 at 16:20
    
bash, and xterm –  NiteRain Jan 25 at 19:50
    
What is in your ~/.bashrc? –  falconer Jan 25 at 22:12
    
I think what happened was when I moved all my dot files because I wanted everything to reset like knew. So I ended up bring back my .xbindkeysrc, and everything started to work fine. –  NiteRain Feb 7 at 4:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.