Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use mouse bindings in the Compiz Desktop Wall to go to different Workspaces by clicking the mouse in the corners. Does anyone know how to make this work?

I've already tried to do it so in CCSM and in gconf-editor (apps -> compiz -> plugins-> wall-> options) but I can't enable it. The configuration is there but it's not working.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

It looks like I found a way around to deal with the problem for binding the mouse corner over Unity. To do this I installed a program called xdotool to be able to execute commands to be sent till X. I found this answer over the OMG Ubuntu when they talk about binding the upper-left corner to auto open the Desktop Wall utility and for my surprise it worked like a charm. So here go the steps to do for making this way around.

Install xdotool:

sudo apt-get install xdotool

Open ccsm and go to your settings in Desktop Wall (Or whatever you want to bind, Ring Swichter for example)

pic_01

Look at the commands that you have for binding the edge that you want. For me for example I have to command to switch till the left workspace is ctrl+alt+Left. This is the keystrokes that you have to know to create your binding edge. The others bindings, in my case are ctrl+alt+Rigt, ctrl+alt+Up and ctrl+alt+Down.

pic_02

In ccsm go to the Commands option

pic_03

Here we have to enter the xdotoll commands. At command line 1 I already entered the command to open the Unity Desktop Wall Utility so at command line 2 I put the command:

xdotool key ctrl+alt+Rigth

Now go to Edge Bindings tab to create the edge bind.

pic_04

Now click over the Run command 2 to create the bind.

pic_05

Choose the right corner and click OK

pic_06

At this point the ccsm might pop-up that if you want to create this bind you have to disable the Flip Edge effect. I dont even knew that I had this on, it might be enable by default from the Unity. Thats no problem in disable it and enable this bind, so just disable the Flip Edge and enable this new bind (This one is for the Flip Edge effect is from rotate cube binding, and at this example we are using the Desktop Wall, so if you dont had the rotating cube enable it might dont pop up this message).

For creating the new binds for the other corners you just have to follow the same steps as you did for creating the right edge. But please read about the left-edge. The code for the other edges are:

xdotool key ctrl+alt+Up

xdotool key ctrl+alt+Down

The Left edge

xdotool key ctrl+alt+Left

For the left-edge dont use the left corner, instead use the lower-left corner or the upper-left corner. Because the left edge is used by the Unity to hide/access the Unity launcher (dock) and if you disable the default Unity effect IT WILL BROKE your Compiz/Unity. So be careful about disabling the unity effect if it pop it.

So once again, if pop up a compiz message asking for disable the Unity dont disable it, just change the corner to lower-left or upper-left corners.

I hope that it could help you out.

share|improve this answer

That appears to be a bug and it's not only you but there are others. For example, I face similar issues when I try enabling mouse bindings for Ring Switcher. See Ring Switcher in Unity - Mouse combinations don't work. When I posted the same question in Ubuntu Forums I was suggested to enlist myself in this bug report and add a comment as well. I would suggest you to do the same.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.