Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I want to use a base16 colorscheme from here. The steps I followed:

  1. cloned the repo
  2. ran the scripts
  3. changed the terminal profile to base16-default (which did change the colors)

This is the result compared with the screenshot in the repository's readme.


I'm running 12.04. Here's some more info.

$ echo $TERM

And my .bashrc.

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
debian_chroot=$(cat /etc/debian_chroot)

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color) color_prompt=yes;;

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt

if [ -n "$force_color_prompt" ]; then
if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
# We have color support; assume it's compliant with Ecma-48
# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
# a case would tend to support setf rather than setaf.)

if [ "$color_prompt" = yes ]; then
PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
alias ls='ls --color=auto'
#alias dir='dir --color=auto'
#alias vdir='vdir --color=auto'

alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands. Use like so:
# sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
. /etc/bash_completion

Why is it showing wrong colors in my terminal?

share|improve this question
Have you set set t_Co=256 in vimrc? – edwin Jan 25 '14 at 17:03
Yes, but the problem not only about vim. I don't use a vim colorscheme; the colors in the shell are just the same. – Chiel ten Brinke Jan 25 '14 at 17:10
What terminal are you using, GNOME's, Xfce's? Have you checked the colors in the preferences? (Also, don't expect Vim or the terminal to pick up the color combinations automagically :) – edwin Jan 25 '14 at 17:15
As the title and tags say, I use the gnome-terminal. And yes, I activated the colorscheme. – Chiel ten Brinke Jan 25 '14 at 17:17
Can you upload your bashrc? And can you edit the question to reflect the steps you follow, please? – edwin Jan 25 '14 at 17:30

3 Answers 3

The script in base16-gnome-terminal installs the Base 16 Default Dark profile for the Gnome terminal. In order to actually use it, you need to activate the profile via TerminalChange ProfileBase 16 Default Dark which applies the profile to the current session.

You probably want to use it as default profile. In order to do that, you need to go to the Profile preferences via EditProfiles… and choose the Profile used when launching a new terminal.

Additionally the Gnome terminal has 256 color support, which you might like to activate. In order to do that, you need to run source script from base16-shell. To make the changes permanent add the following lines to your ~./bashrc file, presuming you're using bash:

# Base16 Shell
[[ -s $BASE16_SHELL ]] && source $BASE16_SHELL

Try to run the colortest script from the base16-shell repository in a new terminal session to see if everything worked.

share|improve this answer

If I'm not mistaken, you should also run appropriate shell script in your bashrc.

share|improve this answer
I don't believe this is correct for Gnome Terminal, which has its own color profile scheme that can be (and is) used by base16. – Andrew Moylan Sep 7 '14 at 23:47

The Gnome Terminal profiles for base16 seem to only use 10 of the 16 colors. It may be a bug. I reported it as this issue in the base16-builder repository.

I think this means that the only solution for now is to either fix the issue in base-16 builder, or else manually set the 16 colors in Gnome Terminal.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.