Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install anything with apt-get. I think this problem is due to gpg error of some kind. I have done almost everything on the net as per my belief. this is what happens when I run apt-get update.

mody@ubuntu:~$ sudo apt-get update
Get:1 http:/dl.google.com stable Release.gpg                                  
Get:2 http:/dl.google.com stable Release                                      
Ign http:/dl.google.com stable Release                                        
E: GPG error: http:/dl.google.com stable Release: The following signatures were invalid: NODATA 1 NODATA 2
mody@ubuntu:~$ 

I tried these

mody@ubuntu:~$ sudo apt-get clean
mody@ubuntu:~$ sudo apt-get update && sudo apt-get upgrade
Get:1 http:/dl.google.com stable Release.gpg
Get:2 http:/dl.google.com stable Release                                      
Ign http:/dl.google.com stable Release                                        
E: GPG error: http:/dl.google.com stable Release: The following signatures were invalid: NODATA 1 NODATA 2

didn't work

mody@ubuntu:~$ sudo apt-get update -o Acquire::http::No-Cache=True
Get:1 http:/dl.google.com stable Release.gpg
Get:2 http:/dl.google.com stable Release                                      
Ign http:/dl.google.com stable Release                                        
E: GPG error: http:/dl.google.com stable Release: The following signatures were invalid: NODATA 1 NODATA 2

didn't work

mody@ubuntu:~$ sudo apt-get update -o Acquire::BrokenProxy=true 
Get:1 http:/dl.google.com stable Release.gpg
Get:2 http:/dl.google.com stable Release                                      
Ign http:/dl.google.com stable Release                                        
E: GPG error: http:/dl.google.com stable Release: The following signatures were invalid: NODATA 1 NODATA 2
mody@ubuntu:~$ 

even this

Click System>>Administration>>Software Sources Click the Download From menu and choose Main Server Type the following in terminal.

sudo apt-get update

Run the update manager again.

but did not work

I also changed the sources with one available on ubuntu site. i dont know why i did that but that didn't help

Did a force update. problem persists.

mody@ubuntu:~$ sudo apt-get update -f

[sudo] password for mody: Get:1 http:/dl.google.com stable Release.gpg Get:2 http:/dl.google.com stable Release
Ign http:/dl.google.com stable Release
E: GPG error: http:/dl.google.com stable Release: The following signatures were invalid: NODATA 1 NODATA 2

Frustrated.

Synaptic is not installed as well as aptitude. changing download server to everything possible from anything did not help either.

PS: link were giving me problem with posting so i delete '/' where '//' were present

SOLVED

as @arhimed suggested I did

System>>Admin >> Software sources and on the tab 'Other Software' unchecked everything with dl.google.com

Could not have guessed it was asking to update chrome but was failing every time.

thanks every one for their quick support

share|improve this question

marked as duplicate by Eric Carvalho, BuZZ-dEE, 123456, Warren Hill, nux May 24 at 15:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@Azker as this sudo apt-get install -f command do a force update? –  Avinash Raj Jan 25 at 12:17
    
edit your question and post the output of 'cat /etc/apt/sources.list' and 'ls /etc/apt/sources.list.d/'. I'm sure there are some left entries in those directories. You can also go to System>>Administration>>Software Sources and on tab Other Software uncheck all with dl.google.com –  arhimed Jan 25 at 12:19
    
EDIT: Try a force update > sudo apt-get update -f .. @AvinashRaj - thank you for pointing out. –  AzkerM Jan 25 at 12:23
    
-f, --fix-broken Fix; attempt to correct a system with broken dependencies in place.@Azker -f doesn't means for force. –  Avinash Raj Jan 25 at 12:31
    
@arhimed that did it. thanks a ton!! System>>Administration>>Software Sources and on tab Other Software uncheck all with dl.google.com –  Pramod Mody Jan 25 at 13:39

1 Answer 1

The key for signing downloaded packages from the google Linux software repository may need to be re-imported. This can be done with the following line in a terminal

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Alternatively we can also download and save the key to then import it manually.

Source: Google

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.