Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok so, here's the thing. I have an 256GB SSD and a 2TB HDD in my system. I had windows 7 on the SSD until a couple of days ago and ubuntu on a partition on my HDD. Not so familiar with ubuntu btw, just getting into it.

I had some issuse with windows so I decided to switch to ubuntu full time, but I needed to keep windows for some essential software.

Ok, main story now. Ubuntu on SSD, no problem. Had windows on a partition on the HDD, but it didn't boot.
At this point I already switched to ubuntu and made both partitions of the HDD, the storage one and the windows one, auto-mount on startup.
I did this through the "Disks" application(program? idk, new to ubuntu). When I realized windows won't boot, I went to gparted, formated the partition, deleted it, recreated it and reinstalled windows on it, but I changed the name of the partition from "New Volume" to "windows".

Apparently, the setting that auto-mounts "New Volume" is still active and it's trying to mount a drive that no longer exists since I'm getting that message before startup.

How can I fix this? Is there some way I can see the list of auto-mounting drives in the terminal so I can delete them? I've googled for about 2 hours with nothing similar to my situation so I came here. Sorry if it's already been answered somewhere.

Thanks in advance.

EDIT:

natkoui@natko-ubuntu:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/ubuntu--vg-root /               ext4    noatime,errors=remount-ro 0     1
# /boot was on /dev/sda1 during installation
UUID=7786039f-4196-4d35-a746-35a2d2521e76 /boot           ext2    defaults        0       2
/dev/mapper/ubuntu--vg-swap_1 none            swap    sw              0       0
/dev/disk/by-uuid/84DEFF8BDEFF7430 /media/natkoui/New\040Volume auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/64E66D6AE66D3D84 /media/natkoui/Storage auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/295E2E3F4411E9C2 /media/natkoui/windows auto nosuid,nodev,nofail,x-gvfs-show 0 0
share|improve this question
    
Ctrl+Alt+t then run cat /etc/fstab , add results to the question. –  Sneetsher Jan 25 at 11:41
    
Ok, I added it. The old, non-existent partition appears to be there. Any way to remove it? –  natkoui Jan 25 at 12:26

2 Answers 2

up vote 2 down vote accepted

Make backup:

sudo cp /etc/fstab /etc/fstab_backup

Then remove just that line of /media/natkoui/New\040Volume

sudo gedit /etc/fstab
share|improve this answer

Just some background on the issue:

By changing your partition in GParted you also changed it's unique identifier number (aka UUID). However from your ftsab Ubuntu was not aware of this. It still assumes tzhe drive is present and tried to mount it, of course with no success, hence the error you got. The solution is to remove this fstab entry.

Simply renaming a partition by giving it another label would not change it's UUID but the mount point when is generated from the disk label may be renamed then.

Other than by UUID we can also mount a disk by label from the /etc/fstab:

This has the advantage that we can change drives, alter partitions or else without an issue as long as the drive will get the identical label as listed in the fstab. The obvious disadvantage is issues that may come from multiple drives having the same label. We have to take care of this by ourselves.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.