Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is 2nd question following previous one posted but regarding installing 32bit library on 64AMD system of 13.10

From the first question, as Avinash Raj told I finished installing deb packages. Next, I tried to run this with hwp7 command but it showed

 bash: ./hwp7: No such file or directory

but that file EXISTED in specified folder as Excutable, So I searched for the symptom and found this link that I should install libraries for 32bit.

So I tried to install this ia32-libs package but got this results

user@chrubuntu:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate
user@chrubuntu:~$ 

So I installed recommended alternative libs and ran hwp7 again and it showed this (Thank got! it finally told me what is missing in detail, though still error...)

user@chrubuntu:~$ hwp7
hwp7: error while loading shared libraries: libXfixes.so.3: cannot open shared object file: No such file or directory
user@chrubuntu:~$ 

I searched for library package that include this libXfixed.so.3 file in debian and ubuntu sites and instead of dpkging it, extracted this files and copied only needed file into the library folder of hwp7(Hangul 2008) program, and made a soft link from /usr/lib to /usr/lib/haansoft/lib (Reason was that other guys who succeeded told direct installation of this 32bit packages into 64bitAMD could mess up or destroy the library system.)

And...The problem is that this kind of missing packages and search and Extraction and link repeated and repeated...for 3hours. These are list of libraries I downloaded.

/home/user/Downloads/libssl0.9.8_0.9.8o-7ubuntu3.1_i386
/home/user/Downloads/libgcc1_4.7.2-5_i386
/home/user/Downloads/libstdc++6_4.4.5-8_i386
/home/user/Downloads/libgconf-2-4_3.2.5-1+build1_i386
/home/user/Downloads/libfreetype6_2.4.9-1.1_i386
/home/user/Downloads/libx11-6_1.5.0-1+deb7u1_i386
/home/user/Downloads/libfontconfig1_2.9.0-7.1_i386
/home/user/Downloads/libxrender1_0.9.7-1+deb7u1_i386
/home/user/Downloads/libxft2_2.3.1-1_i386
/home/user/Downloads/libcups2_1.5.3-5+deb7u1_i386
/home/user/Downloads/libglib2.0-0_2.33.12+really2.32.4-5_i386
/home/user/Downloads/libexif12_0.6.20-3_i386
/home/user/Downloads/libpng12-0_1.2.49-1_i386
/home/user/Downloads/libxml2_2.8.0+dfsg1-7+nmu2_i386
/home/user/Downloads/libcairo2_1.12.2-3_i386
/home/user/Downloads/libpango1.0-0_1.30.0-1_i386
/home/user/Downloads/libgdk-pixbuf2.0-0_2.28.2-1+b1_i386
/home/user/Downloads/libatk1.0-0_1.30.0-0ubuntu2_i386
/home/user/Downloads/libgtk2.0-0_2.24.10-0ubuntu6_i386

Installing this packages with :i386 command does not work.

user@chrubuntu:~$ sudo apt-get install libstdc++6:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libstdc++6
E: Couldn't find any package by regex 'libstdc++6'
user@chrubuntu:~$

Should I continue this tedious search, download, cp, linking libraries; or is there any command to install 32bit shared libraries at once or figure out missing libraries for running hwp7(Hangul 2008)?

First question.

Installation of i386 Deb(Hangul 2008) into AMD64 architecture; dpkg/library error

share|improve this question
    
It is better to use Synaptic advanced package manager : sudo apt-get install synaptic. –  Sneetsher Jan 25 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.