Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Does anybody know how to configure Wi-Fi on a Lenovo ThinkPad s440 with Ubuntu 12.04 LTS?

I can't configure it even with LAN. Wi-Fi is the first thing I need. I can't find any drivers for Linux. As I see it from (official specs link) Ubuntu uses "Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller" to establish network.

Can anybody suggest a solution? A driver, a way to configure Wi-Fi or anything?

$ lspci -nn | grep 0280
04:00.0 Network controller [0280]: Intel Corporation Device [8086:08b2] (rev 73)
share|improve this question

1 Answer 1

Answered own question here: http://unix.stackexchange.com/questions/110825/lenovo-thinkpad-s440-network/110829#110829. LTS version is preferred over 3months support but maybe someone considers easier solution - install Ubuntu 13.10.

UPDATE: Ubuntu 13.10 failed to recognize video card and can't load low graphics mode. Also tried to install iwlwifi into /etc/modules, but modprobe no luck.

HORAY! I installed iwlwifi module using instructions from another thread. I just needed to know my Intel 7260 to find this answer.

So, steps (by chili555) are: """ I suggest you download this to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.11-rc3/backports-3.11-rc3-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

cd Desktop/backports-3.11-rc3-1/
make defconfig-iwlwifi
make
sudo make install

Now download the required firmware here: https://dl.dropboxusercontent.com/u/58267392/iwlwifi-7260-7.ucode.zip Please download it to your desktop. Right-click and select 'Extract Here.' Now open a terminal and do:

sudo cp Desktop/iwlwifi-7260-7.ucode /lib/firmware/
sudo modprobe -r iwldvm  <--If it is not loaded, OK, please proceed
sudo modprobe -r iwlwifi <--If it is not loaded, OK, please proceed
sudo modprobe iwlwifi

Your wireless should now be working. """ Thanks a lot!

UPDATE: Problem with the intel wireless 7260 driver

share|improve this answer
    
The device quoted above is ethernet, not wireless. It's impossible to propose a better solution without details: lspci -nn | grep 0280. If yours is the Intel 7260 device, there are several threads here about how to install it. –  chili555 Jan 25 at 2:24
    
Thanks a lot! I could first define my device, then try to get precise solution. –  boldnik Jan 25 at 9:41
    
May we assume it's now working correctly? –  chili555 Jan 25 at 13:19
    
Yes, everything works now, thank you very much! –  boldnik Jan 26 at 12:34
    
Now I have another problem - system crash and unstable wifi. –  boldnik Jan 27 at 21:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.