Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This happens occasionally, and I never know how to fix it without deleting the panel and adding a new one. Any help would be appreciated.

Weird panel

share|improve this question
    
I've run into this problem a lot also - I ended up enabling Kill XServer Sequence (Ctrl+Alt+Backspace) and just restart the X Session. –  Marco Ceppi Sep 13 '10 at 14:16
    
thanks to @Marco Ceppi's comment on my question, I can fix it by [doing this][1] it doesn't fix the root of the problem as @Jacob Peddicord said, but it let's me carry on with my work. [1]: tech-recipes.com/rx/7618/… –  tomwolber Sep 13 '10 at 14:51
    
this is what I ended up doing! THANKS! –  tomwolber Sep 13 '10 at 14:52
    
Thanks for all the great info –  tomwolber Sep 13 '10 at 14:52
2  
Quick way to restart the panel: Alt+F2 and enter killall gnome-panel –  8128 Oct 25 '10 at 12:32
show 1 more comment

5 Answers 5

Unfortunately, no one really knows of a proper solution to this yet. You can read and subscribe to bug 439448 if you're interested in updates, but be prepared for a lot of email.

At the moment, just have to kill the panel when you see it happen and hope it doesn't happen again. It's extremely difficult to debug due to the fact that it only happens every once in a while.

share|improve this answer
4  
Quick way to restart (kill) the panel: Alt+F2 and enter killall gnome-panel –  8128 Oct 25 '10 at 11:35
add comment

Whenever I trip on this panel visual corruption, I do a right click on the panel bar, select "Preferences" or "Properties" (sorry, my language is Italian, I am not sure which is the correct menu option equivalent to "Proprieta") and just increase the height of the panel by a couple of pixels, WITHOUT CLOSING THE WINDOW.

Gnome repaints the higher panel bar almost on the fly, correcting whatever defect there was, and as soon as it has done so, I revert the pixel height back to the previous value and close the panel "Properties"/"Preferences" window.

share|improve this answer
add comment

I had the same problem, but I resolved this issue using a script I found in http://www.omgubuntu.co.uk/2010/09/how-to-restore-default-gnome-panels-in-ubuntu/ I normally don't use script's and such, but this one came from a site that I trust.

share|improve this answer
    
That doesn't fix the root cause -- even after restoring your panel to GNOME defaults, you may see panel corruption pop up again. It's bizarre. –  Jacob Peddicord Sep 13 '10 at 14:36
    
I know. But for me, the doubling name ends up taking the space needed for the shutdown button. So, I restart the panel in order to not use the ctrl-alt-del alternative –  Habkost Sep 13 '10 at 14:39
2  
True. Here's another tip: Super+S (Win+S) will bring up the shutdown panel menu even if you can't see the indicator for it; it's handy when the issue in the question pops up. :) –  Jacob Peddicord Sep 13 '10 at 14:53
    
thanks! I'm a noob in ubuntu, and didn't found the shortcuts yet =) –  Habkost Sep 13 '10 at 15:05
add comment

Run alt+f2 gnome-panel --replace to fix the problem. Hopefully this will be fixed by the next release :) (just wishful thinking)

share|improve this answer
add comment

I workaround this by adding the command killall gnome-panel to System->Preferences->Startup Applications

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.