Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.10 on my laptop lenovo ideapad s405. It's showing all wifi connection.and also connecting to wifi. But it doesn't doing data transfer. Pages are not loading in browser. I have check internet connection its working fine with ethernet connect but not with wifi. Network adpter:Broadcom Corporation BCM4313 802.11bgn Wireless network adapter. Please help.

share|improve this question
    
I had this problem before with my Lenovo Thinkpad X131e. Ultimately, I ended up buying another adapter for Ubuntu. Luckily, I was able to get a pretty good one for about $10. –  Dillmo Jan 24 at 11:53
    
But WiFi was working fine with preinstalled windows. So why do i buy new adapter when its working. –  Rahul Jan 24 at 12:21
1  
Please edit your question to add details of your wireless device from the terminal command: lspci -nn | grep 0280 –  chili555 Jan 24 at 13:42
    
Its Broadcom Corporation BCM4313 802.11bgn Wireless network adapter. –  Rahul Jan 24 at 14:12
    
@Rahul That same driver is what caused me trouble. The device worked on Windows, but there were no good Linux drivers. –  Dillmo Jan 25 at 12:55

1 Answer 1

Had similar issue on one Xubuntu 13.10 box.

this was my solution and it worked (do this when connected with Ethernet of course)

sudo apt-get remove --purge bcmwl-kernel-source

sudo apt-get install linux-firmware-nonfree

sudo modprobe b43

reboot and wireless should be working now.

share|improve this answer
    
No its not working for me..:( –  Rahul Jan 24 at 19:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.