Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a kinda weird question I don't know what to file it under but this is the behaviour I observe when I try to access pages like facebook (it happened once with google as well. Happens with tumblr now too).


This is a new thing so I haven't really tried to figure out which pages trigger this, I just switched to firefox which seems to work ok (because I am in the middle of some work that needs to be done without interruptions.

The first time this occured I left the page open and tried to figure out what happened the whole graphics turned off and it went to terminal.

I recently installed a ram dimm (if you think that might be somehow related)

My setup:

       CPU: Intel® Pentium(R) CPU B960 @ 2.20GHz × 2 64bit
       GPU: Intel® Sandybridge Mobile 
       RAM: 7.6G

Thanks in advance!

edit: appears to be happening with bookmark manager as well!

share|improve this question
Looks like the bug is fixed now! See my updated answer. – Dmitry Pashkevich Jan 30 '14 at 19:24
up vote 3 down vote accepted

UPDATE As of Jan 30, 2014, the bug seems to be fixed. With the latest drivers from oibaf's PPA, there are no graphic glitches in Chrome.

Are you using oibaf's ppa with latest graphics drivers? Looks like there's a bug introduced in recent Mesa builds:

Bug 73978 - Intel driver breaks hardware accelerated flash on Chrome (supposedly related to Flash plugin but it's unconfirmed yet).

The current workarounds are:

EITHER: disable accelerated compositing for now in Chrome by launching it with the following flag:

google-chrome --disable-accelerated-compositing


  1. For some reason disabling Accelerated compositing on all pages in chrome://flags didn't do the trick for me
  2. Make sure you stop all chrome's processes by issuing killall chrome before launching it with the command line flag

OR: revert to older graphics drivers by purging oibaf's PPA: sudo ppa-purge ppa:oibaf/graphics-drivers (install ppa-purge if you don' have it)

Also keep an eye on this forum thread on Phoronix: Updated and Optimized Ubuntu Free Graphics Drivers

share|improve this answer
I had to reinstall oibaf/graphics-drivers, then ues ppa-purge to successfully revert to original drivers. Thanks Dmitry – Julio Jan 26 '14 at 14:02

Bad RAM can shift graphic object positions to a different spot. It looks like someone has grabbed one tiny spot on some object in the scene and pulled it to another position. Check if your visual artifacts problem persists if you remove the RAM that you recently installed. Visual artifacts can also be caused by a bad graphics processor, including artifacts that resemble those in your screenshot, however graphics cards often store data in the motherboard RAM, so sometimes it can cause artifacts which look like graphics card RAM problems.1

1PlayTool: Diagnose video card problems by comparing with example corrupted screens

share|improve this answer
Thanks for the quick reply! Weirdly enough you were right about the memory issue. memtest86+ found some bad memory segments, however I have to accept Dmitry's answer because the issue persisted after removing the new DIMM. – jaivalis Jan 25 '14 at 10:55

If you are using xorg-edgers, then remove this source with the command

sudo ppa-purge ppa:xorg-edgers/ppa

After reboot, and check the Google chrome, it should work

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.