Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I am not tech savvy, so please give me explicit instructions if you have a solution.
  2. This problem has gotten progressively worse.

Here goes: I've been using Ubuntu 12.04 with a D-Link wireless router for over a year without problems. The problem began a few weeks ago. It would not connect to the router, though it recognized the network. I could usually solve this by rebooting the router. That is not working any more. Now, most of the time I open Ubuntu it will not connect at all (I have dual-boot with Windows and an iPad and in most cases they can still connect). Yesterday, the wireless worked on one occasion, but not on two others. Today it is not working at all and when I try a wired connection that is not working either. Please help!

output of sudo lshw -C network -numeric

*-network
description: Wireless interface product: Centrino Advanced-N 6230 [Rainbow Peak] [8086:91] vendor: Intel Corporation [8086] physical id: 0 bus info: pci@0000:02:00.0 logical name: wlan0 version: 34 serial: 88:53:2e:62:bf:97 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-58-generic-pae firmware=18.168.6.1 ip=192.168.0.103 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn resources: irq:49 memory:c7400000-c7401fff *-network description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10EC:8168] vendor: Realtek Semiconductor Co., Ltd. [10EC] physical id: 0 bus info: pci@0000:05:00.0 logical name: eth0 version: 06 serial: f0:bf:97:da:88:ca size: 10Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s resources: irq:47 ioport:3000(size=256) memory:c3404000-c3404fff memory:c3400000-c3403fff

BTW, I have recently come upon some evidence that the problem might be with the router. Strange that only my Ubuntu operating system doesn't connect regularly, but my neighboir told me that he has had some trouble connecting with his Mac, though that is usually solved simply by rebooting the router. Lemme know if you have any insights.

share|improve this question
    
Could you append to the question the output of sudo lshw -C network -numeric? –  Sneetsher Jan 24 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.