Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Unity and a gnome-panel panel at the bottom at the same time. Is there a way to disable the gnome-panel's launcher? At the moment, both Unity's and gnome-panel's launcher pop up when I press Alt+F2.

Thanks in advance!

share|improve this question

3 Answers 3

up vote 3 down vote accepted

You can disable Gnome Panel launcher using Gnome lockdown feature.

Execute this command:

gconftool-2 -t bool -s /desktop/gnome/lockdown/disable_command_line true

(You can inspect this option using gconf-editor) While Unity will ignore this setting, Gnome launcher will be effectively disabled.

share|improve this answer
    
That works, thanks! –  Ian Jun 13 '11 at 12:42
    
Alternativly, I could have just selected or deleted the shortcut for the gnome-panel launcher, the shortcut for the unity launcher is set in compizconfig-settings-manager. –  Ian Jun 13 '11 at 12:44

The better way is to reconfigure the shortcut for gnome-panel launcher. Run

gnome-keybinding-properties

and then, in the Desktop section, you'll see something like "Show the dialog box 'Launch an application' from panel" (sorry I don't know the translation in english) and change the keybord shortcut.

share|improve this answer
1  
If I change the keyboard shortcut, the unity launcher will also not show. I'm looking for away to disable the gnome-panel launcher but keep the unity one. –  Ian May 7 '11 at 14:44

killall -9 gnome-panel

Should work

share|improve this answer
    
I want to keep my gnome-panel running, i just don't want the launcher. And if you killall , it just reloads :) –  Ian May 7 '11 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.