Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm posting here for the first time, though reading this site looking for solutions almost every day.

I'm trying to install Ubuntu 12.04.3 with soft-RAID on a IBM server with UEFI support. After the installer reboot it fails with grub error: unknown filesystem. If I put the HDDs to another machine (a generic PC without UEFI) it boots correctly. I suspect it's either an issue with the UEFI/Legacy modes or with the hardware in some way, though may be the installer failed to detect/configure something and it should be fixed manually.

Here are the details.

The IBM server:

  • Brand new IBM System x3100 M4, firmware v1.07, IMM v3.65 (up-to-date)
  • Intel Xeon E3-1240v2 @ 3.4GHz
  • 8Gb ECC RAM (all memtests OK)
  • 2 x SATA 1Tb WD RE4 (WD1003FBYZ)
  • The system has a fake-RAID, but it is disabled in the BIOS (Configure SATA as: AHCI).

The generic PC:

  • Asus P5KPL
  • Intel Pentium 4
  • 4Gb RAM
  • Same HDDs from the IBM server

The intended install:

  • Ubuntu 12.04.3 Alternate x64 (ubuntu-12.04.3-alternate-amd64.iso)
  • RAID1 for /boot (100Mb)
  • RAID1 for / (10Gb)
  • NO LVM

(The separation of /boot and / is actually for LUKS to be installed on top of the / raid array, but this is another issue)

The firmware of the IBM server supports UEFI in some awkward way: it boots the install CD in Legacy/MBR and HDDs/USB Storage in UEFI with some fallback to MBR. There is no way to change it or fine-tune it somehow (or at least I didn't figure out how).

Tried both on the IBM server: image burned on a CD (installs in Legacy (MBR), partition table msdos) and on a USB memory (installs in UEFI, partition table GPT with EBP). Both produce the grub rescue error. Same install on the generic PC (or disks with the install on the IBM server moved to the generic PC) boots correctly.

Here is how I install it (from a CD, in Legacy (MBR) mode):

Expert mode, default/basic options in the first steps up to Partition disks. There I recreate an empty partition table (msdos) on both HDDs, then, after creating/setting everything, it looks this way:

RAID1 device #0 - 98.4 MB Linux Software RAID Array
>     #1            98.4 MB     F  ext4          /boot
RAID1 device #1 - 10.0 GB Linux Software RAID Array
>     #1            10.0 GB     F  ext4          /
SCSI1 (0,0,0) (sda) - 1.0 TB ATA WDC WD1003FBYZ-0
>     #1  primary   98.6 MB  B  K  raid
>     #2  primary   10.0 GB     K  raid
>         pri/log  990.1 GB        FREE SPACE
SCSI3 (0,0,0) (sdb) - 1.0 TB ATA WDC WD1003FBYZ-0
>     #1  primary   98.6 MB  B  K  raid
>     #2  primary   10.0 GB     K  raid
>         pri/log  990.1 GB        FREE SPACE

Do you want to boot your system if your RAID becomes degraded? -> Yes
No swap (there is no need for it in my case, and it should not affect the boot process).

The rest of the steps are also completed with the default options (kernel: linux-generic-lts-raring, drivers: generic/targeted (tried both), software: none).

Install the GRUB boot loader to the master boot record? -> Yes

Running "grub-install /dev/sda /dev/sdb"...


error: unknown filesystem
grub rescue>

If I enter there (this is on the IBM server):

grub rescue> insmod part_msdos
grub rescue> insmod normal
grub rescue> normal

the system boots correctly.. sometimes.. and sometimes it just reboots seconds after the last line entered (grub rescue> normal), as if ctrl+alt+del pressed. And once I've even seen

unaligned pointer 0xbf099492. [hmm, 32-bit address in 64-bit install??]
Aborted. Press any key to exit.

When it does boot, there is a delay of some 15s after pressing enter on the last line and before it starts accessing the HDDs for the boot sequence.

Please note: all (quick and full with 7 passes) memory tests (in the BIOS and memtest86+ of the install CD) complete without errors and the same install but without raid (same /boot and / partitions on one HDD) boots correctly.

Looks like a problem related to UEFI/Legacy modes (could it be that the firmware of the IBM server tries to boot the system in UEFI mode and GRUB, expecting GPT, doesn't load msdos partition table stuff or something similar?), but I don't have enough GRUB/initramfs/kernel/UEFI knowledge to figure it out. Another possibility I see is that the firmware/IMM resident code on the IBM server (which is a hypervisor, sort of a virtual machine that runs without interruptions during the OS reboots and halts) interferes somehow with the boot process (this would be the worst, unfixable case).

Here is the BootInfo summary from boot-repair (which actually doesn't fix this problem) executed from a LiveCD in Legacy (MBR) mode (ubuntu-12.04.3-desktop-amd64.iso) on the IBM server: http://paste.ubuntu.com/6801133/.

Any ideas? Any suggestion how to debug step-by-step the bootloader? Please let me know if additional information is needed. Thanks in advance!

P.S. I've asked the same question on UbuntuForums, here is the link for future if someone encounters the same problem: http://ubuntuforums.org/showthread.php?t=2201239.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.