Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My fingers got ahead of me today and I managed to disable Java for Webex on my machine.

(Install details: Ubuntu 12.04 32bit, Chrome 32.0.1700.77, Java v7, update 51, Webex working fine for a year till now. Tried Firefox with same result.)

I hurriedly clicked past a Java dialog box similar to this one and checked the "Do not show this again..." box.

enter image description here

Note that this is not the exact dialog box, it was the most similar one I could find. I don't remember the yellow box with "This application will be blocked..."

Now when I start my meeting...

enter image description here

I wind up with just a blank webpage...

enter image description here

Therefore I think (not sure) that I inadvertently disabled java needed for this app to run. Can anybody tell me how to re-enable it? I've Googled for half an hour and am coming up dry.

Java verified on the machine by Java webpage:

enter image description here

Thanks in advance for any help!

share|improve this question

2 Answers 2

I encountered the same problem and discovered the solution.

The problem is that the Webex Java applet is incompatible with Java 7 update 51. The java update tightened the security controls on Java web applets and the version of the Webex java applet that both you and I are using isn't yet updated to meet those tightened security controls.

Until the version of the Webex java applet that we are using gets updated, there is a work-around. You can open the "Oracle Java 7 Web Start" control panel that should have gotten installed in Ubuntu with Java 7 and change one or both of the following settings in the "Security" tab: a) Change the Security Setting from High to Medium OR b) Add the https address of your webex server to the "Exception Site List". For example if the URL to your WebEx server is https://foobar.webex.com then put "https://foobar.webex.com" in the "Exception Site List".

Once you do one of those two things Webex should work for you again. It works for me now.

share|improve this answer
    
on my local control panel is here /usr/lib/jvm/jdk1.7.0/jre/bin/ControlPanel –  Bogdan Mar 21 at 15:23

You should add the desired site exuting java in your Exception List.

for ubuntu with official ORACLE java 8:

sudo /usr/lib/jvm/java-8-oracle/jre/bin/ControlPanel

Then security tab to add your website.

Take a look on official oracle website:

https://www.java.com/en/download/exception_sitelist.jsp

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.