Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i recently bought a new system, dell with Intel® Core™2 CPU 6700 @ 2.66GHz × 2 processor, 2g ram, hdd, etc, but no graphics. to save on money i skipped gettiing a windows key and went with ubuntu 12.04 LTS. i bought videocard online, an xfx amd/ati radeon r7 240 with 2gb of onboard ram. twice now ive tried to install the drivers for it, once direct download from their website and executeing that way, which gave me some sort of error. then i tried sudo apt-get install fglrx fglrx-amdcccle, which also failed. .

Heres what i get under graphics when i type lspci -v:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland [Radeon HD 8500 Series] (prog-if 00 [VGA controller])
    Subsystem: XFX Pine Group Inc. Device 7240
    Flags: fast devsel, IRQ 11
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at dfdc0000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at dc00 [size=256]
    Expansion ROM at dfe00000 [disabled] [size=128K]
    Capabilities: <access denied>

whats going wrong here? im really fustrated cause like 3 days ago i did something and it worked awesome and i even got to where i had fallout new vegas installed and running and running WELL and i clicked something in compiz and lost my top menu bar and launcher menu and all hotkeys >.< not downloading compiz again for a while. anyway anybody been through this?

Probably final edit: Ok so i went through several other distros booting from live usb and attempting to install, but they all fail at some point, usually around graphics stuff. Guess i should have considered getting the newer edition of something with proprititary drivers. Anyway im pretty sure each attempt broke something different so i found an iso for the xp version that i have the key for stickered to the top of the machine, gonna try and dual boot fresh. Ty for the part about the headers, i remember skimming over something about them once, and then ignoring it. that was probably my issue

share|improve this question
sigh. i did something with synaptic package manager, thinking id try a different route, and now it wont boot. obvoiously i have a liveusb to boot from. but am i tottally boned or what? – drunkScientist Jan 23 '14 at 5:23
it depends how bad it is. most of cases can be fixed. where do you stuck now with booting? – t4lwh Jan 23 '14 at 7:25
up vote 1 down vote accepted

Please have linux-headers- of your current running kernel images installed first. This is required when using DKMS to build additional kernel drivers.

ATI kernel driver fglrx is built with DKMS. Also try the latest experimental fglrx-experiment-<vno> fglrx-amdcccle-experimental-<vno>. (search via apt-cache search fglrx). if you have manually edit /etc/X11/Xorg.conf, try define the driver 'fglrx' in section 'Device'.

After restart the machine, verify the driver is loaded correctly from lsmod | grep fglrx. more logs can be analyzed from /var/log/Xorg.0.log or /var/log/lightdm (depending which dm you use)

Added info: Ubuntu Wiki on AMD Howto

share|improve this answer

Hey bud i think it is a problem with an older motherboard with PCI 1 and trying to install a newer card PCI X 3. What you have to do is a custom install off the drivers and not a express install. if that dont work may have to get a PCI express 2.0 card and still do a express install. The same ploblem happened to me and it was saying error 10 standard video graphics (VGA) where the only drivers it would install. i think it may have been a compatability issue with the motherboard.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.