Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before that, I have a running redmine 1.3.2 stable installed from repos, this worked without any big issues.

I am using Ubuntu 12.04 and try to make redmine work using ruby 1.9.1 I have phusion passenger installed and all necessary components. Activated my mod passenger and provided the correct links to load it in apache.

When I try to access locally to my website i get this Passenger error :

Web Application could not be started :

There was an error in your Gemfile, and Bundler cannot continue. (Bundler::GemfileError)
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler/dsl.rb:37:in `rescue in eval_gemfile'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler/dsl.rb:29:in `eval_gemfile'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler/dsl.rb:9:in `evaluate'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler/definition.rb:26:in `build'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler.rb:152:in `definition'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler.rb:115:in `setup'
  /var/lib/gems/1.9.1/gems/bundler-1.5.2/lib/bundler/setup.rb:17:in `<top (required)>'
  /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `require'
  /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in `rescue in require'
  /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/lib/phusion_passenger/loader_shared_helpers.rb:245:in `block in run_load_path_setup_code'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/lib/phusion_passenger/loader_shared_helpers.rb:348:in `running_bundler'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/lib/phusion_passenger/loader_shared_helpers.rb:243:in `run_load_path_setup_code'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/helper-scripts/rack-preloader.rb:100:in `preload_app'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/helper-scripts/rack-preloader.rb:158:in `<module:App>'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/helper-scripts/rack-preloader.rb:29:in `<module:PhusionPassenger>'
  /var/lib/gems/1.9.1/gems/passenger-4.0.35/helper-scripts/rack-preloader.rb:28:in `<main>'

I tried :

gem bundler update gem passenger update

tried to use ruby 1.8....

no success and i am stuck with that error, which doesn't tell me much for now. Any help is upvoted immediately.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.