Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to install gnome3 on my ubuntu but because of some reason, apt-get went into an invalid state after the installation (which was incomplete i think). Whenever I try any apt-get operation, I get an error:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gnome-shell : Depends: gnome-themes-standard (>= 2.91) but it is not installed
E: Unmet dependencies. Try using -f.

When I try sudo apt-get -f install I get:

Unpacking gnome-themes-standard (from .../gnome-themes-standard_3.0.0-2~natty1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/gnome-themes-standard_3.0.0-2~natty1_i386.deb (--unpack):
 trying to overwrite '/usr/share/themes/HighContrastInverse/index.theme', which is also in package gnome-accessibility-themes 3.0.0-0ubuntu1~build2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for gconf2 ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any way to fix this?

share|improve this question
try these| sudo apt-get install -f | sudo dpkg --configure -a | sudo apt-get update | – Uri Herrera May 7 '11 at 5:31
up vote 1 down vote accepted

You're trying to install two packages that contain the file /usr/share/themes/HighContrastInverse/index.theme at the same time. That's not possible. In natty, this file is in gnome-themes-standard 2.91.93-1 and not in gnome-accessibility-themes 2.32.1-0ubuntu1. You have third-party versions of both these packages, so you should report your problem as a bug to that third party. If the packages come from different third parties, then these are two incompatible packages sources, which may or may not be a bug they consider worth fixing. Do make sure that you have their latest version of gnome-accessibility-themes first: run

sudo apt-get update
sudo apt-get install gnome-accessibility-themes

The easiest solution to your problem is to wait for the package provider to fix the packages. Or, if nothing depends on gnome-accessibility-themes, you could try removing it.

The packaging tools actually offer a way to make two packages cohabit even when they provide a file in common. You can rename one of the packages' version of the file with dpkg-divert:

sudo dpkg-divert --rename --package gnome-accessibility-themes \
                 --divert /usr/share/themes/HighContrastInverse/index.theme.gnome-accessibility-themes \

I don't necessarily recommend this: there may be other incompatibilities between the packages that you'll only find out later, and it can get messy if there are a lot of conflicting files. If you try the diversion, dpkg-divert --remove --rename --package gnome-accessibility-themes /usr/share/themes/HighContrastInverse/index.theme will cancel its effects.

share|improve this answer
I think the package maintainers realized the problem and fixed it. All I did was apt-get update and apt-get -f install and voila! its fixed :) – jrharshath May 10 '11 at 3:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.