Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i tried to install lxc-docker-0.7.6 on ubuntu 13.04, i get the following errors:

The  following package was automatically installed and is no longer required:
  libsdl-ttf2.0-0
Use 'apt-get autoremove' to remove it.
The following NEW packages will be installed:
  lxc-docker-0.7.6
0 upgraded, 1 newly installed, 0 to remove and 61 not upgraded.
1 not fully installed or removed.
Need to get 2,681 kB of archives.
After this operation, 14.4 MB of additional disk space will be used.
Get:1 http://get.docker.io/ubuntu/ docker/main lxc-docker-0.7.6 amd64 0.7.6 [2,681 kB]
Fetched 2,681 kB in 3s (857 kB/s)             
(Reading database ... 171665 files and directories currently installed.)
Unpacking lxc-docker-0.7.6 (from .../lxc-docker-0.7.6_0.7.6_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/lxc-docker-0.7.6_0.7.6_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/docker', which is also in package docker 1.4-5ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/lxc-docker-0.7.6_0.7.6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

1 Answer 1

Try the below commands on terminal,

sudo dpkg -r docker
sudo apt-get -f install
share|improve this answer
    
sudo dpkg -r docker worked... –  user238511 Jan 22 at 5:31
2  
then accept my answer. –  Avinash Raj Jan 22 at 5:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.