Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

running Ubuntu Touch on a Nexus 4. I've installed ssh server and have followed the instructions available in the wiki to ssh into the phone, but it tells me connection is refused. Doing the standard ssh phablet@192.168.x.x (getting IP address from ifconfig). I've made the image writable. I've enabled ssh. Now I'm at a loss.

share|improve this question
    
By default SSH is disabled, and SSH-server is already installed. See: askubuntu.com/questions/348714/… What beta-release/date of Ubuntu-Touch are you using? – david6 Jan 24 '14 at 19:55
    
No need to make the image writable. See SSH Ubuntu Touch for a working solution. As always with password-less authentication you need to place a /home/phablet/.ssh/authorized_keys file (with a public key of the PC you're using to access the Ubuntu Touch device) on your device. – Peterino Feb 11 at 23:47

There is an override file /etc/init/ssh.override, which disables password login to ssh. If you were to do

$ ssh phablet@192.168.x.x -v

from your client, you will see something like

debug1: Authentications that can continue: publickey

so, the only authentication option by default is publickey and not password. To enable the password authentication, you can either remove this override file, which you won't be able to do for some reason I can't figure out, or simply empty out the file

sudo tee /etc/init/ssh.override < /dev/null
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.