Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It happens when flat volumes = no. When pulseaudio daemon is starting, it set all volumes to 0dB. On logon screen my speakers sounds like "BOOM!" It is not as annoying to change them every time as changing mic, monitor etc volumes as well. Also i can't use enabled flat volumes because i want independent global volume, if you know what i mean.

Possibly workaround: i made simple script that using commands "set-source-volume" and "set-sink-volume". Would be great if someone tell me the nice place for autostart these commands when daemon starts.

UPDATE: Can i add this script to /etc/init.d/pulseaudio file?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You can add your set-source-volume and set-sink-volume commands directly to the pulse audio startup script located at /etc/pulse/default.pa. Add your commands to the end of that file.

(Or if you are using pulse in system-wide mode then use the /etc/pulse/system.pa file, but this is not the default.)

share|improve this answer
    
Thanks, this working fine. –  DanchiZZ Jan 27 at 7:41
    
I tried both of these options. Neither worked for me. :( Any other suggestions? –  Pretzel Apr 16 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.