Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when executing sudo apt-get install or similar commands, I'm getting this message:

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 postgresql-client-9.1 : Breaks: postgresql-9.1 (< 9.1.11-1.pgdg12.4+1) but 9.1.10-1.pgdg12.4+1 is to be installed
 postgresql-contrib-9.1 : Depends: postgresql-9.1 (= 9.1.11-1.pgdg12.4+1) but 9.1.10-1.pgdg12.4+1 is to be installed
 synaptic : Depends: libvte9 (>= 1:0.24.0) but it is not going to be installed
            Recommends: rarian-compat but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Ubuntu Software Center and Update Manager dont't work either - Software center keeps trying to repair, but it is never succesful, apt-get -f install doesn't help (the repairing is cancelled because of those packages). All error messages has something to do with these packages.

Is there something I can do to get it working?

EDIT: output after 'apt-get install -f':

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libkrb5-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  postgresql-9.1
Suggested packages:
  oidentd ident-server locales-all
The following packages will be upgraded:
  postgresql-9.1
1 upgraded, 0 newly installed, 0 to remove and 256 not upgraded.
4 not fully installed or removed.
Need to get 0 B/3,629 kB of archives.
After this operation, 10.2 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of postgresql-9.1:
 postgresql-client-9.1 (9.1.11-1.pgdg12.4+1) breaks postgresql-9.1 (<< 9.1.11-1.pgdg12.4+1) and is installed.
  Version of postgresql-9.1 to be configured is 9.1.10-1.pgdg12.4+1.
dpkg: error processing postgresql-9.1 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql-9.1-postgis-2.0:
 postgresql-9.1-postgis-2.0 depends on postgresql-9.1; however:
  Package postgresql-9.1 is not configured yet.
dpkg: error processing postgresql-9.1-postgis-2.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql-9.1-pgrouting:
 postgresql-9.1-pgrouting depends on postgresql-9.1-postgis-2.0 | postgresql-9.1-postgis; however:
  Package postgresql-9.1-postgis-2.0 is not configured yet.
  Package postgresql-9.1-postgis is not installed.
dpkg: error processing postgresql-9.1-pgrouting (--configure):
 dependency probNo apport report written because the error message indicates its a followup error from a previous failure.
                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                                    No apport report written because the error message indicates its a followup error from a previous failure.
              No apport report written because MaxReports is reached already
                                                                            lems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql-contrib-9.1:
 postgresql-contrib-9.1 depends on postgresql-9.1 (= 9.1.11-1.pgdg12.4+1); however:
  Version of postgresql-9.1 on system is 9.1.10-1.pgdg12.4+1.
dpkg: error processing postgresql-contrib-9.1 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 postgresql-9.1
 postgresql-9.1-postgis-2.0
 postgresql-9.1-pgrouting
 postgresql-contrib-9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
1  
post the output of sudo apt-get install -f. –  Avinash Raj Jan 21 at 14:54
    
post the output in your question. –  Avinash Raj Jan 21 at 15:10
    
askubuntu.com/posts/408753/edit click this link and then post the output of sudo apt-get -f install. –  Avinash Raj Jan 21 at 15:12
    
ok, I've already edited my post. –  user238312 Jan 21 at 15:19

1 Answer 1

up vote 1 down vote accepted

Try to forcely remove the packages by running the below command,

sudo dpkg --purge --force-all --force-remove-reinstreq postgresql-9.1 postgresql-9.1-postgis-2.0 postgresql-9.1-pgrouting postgresql-contrib-9.1

Then run,

sudo apt-get -f install

Any other method than dpkg --purge --force-all --force-remove-reinstreq won't work in this situation.

share|improve this answer
    
Thanks a lot, it solved my issue. –  user238312 Jan 21 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.