Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 LTS on my laptop dell inspiron 1440. Wired connection works fine. But wireless connection does not work. I installed the driver. I can see my home wireless net work and configured with password. but after configuring it, it keep saying wireless network disconnected. I removed wired connection and internet does not work with wireless even though I see my network. This is what I did after going through previous questions.

lspci -nn to check what driver I need. The output is; Broacom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315 (rev 01)

As per recommendation I did this;

sudo apt-get install linux-headers-generic sudo apt-get install --reinstall bcmwl-kernel-source sudo modprobe wl

Assuming the wireless switch is on, your wireless should now be working; check:

rfkill list all

But I still get this message "wireless network disconnected" and wireless connection does not work. I ran software updates to make sure I am current before doing the above.

I spent lot of time on this. Any help is greatly appreciated.

share|improve this question

2 Answers 2

Your device also has another driver available that sometimes works better. Please get a temporary wired ethernet connection, open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get update
sudo apt-get install firmware-b43-lpphy-installer

Detach the ethernet, reboot and let us know how it's working.

share|improve this answer

I have the same wireless card and this is the procedure I go through on a new install to get my wireless working:

sudo apt-get install firmware-b43-lpphy-installer b43-fwcutter

then with your favorite text editor open up the file blacklist.conf in the /etc/modprobe.d/ directory and comment out 'blacklist bcm43xx' by putting a # in front of the text. Should look something like this:

# replaced by b43 and ssb.
#blacklist bcm43xx

You will probably need to restart your computer for the wireless to register. hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.