Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install OpenCPN, a navigation and chart program. The install guide recommend this:

It is also possible to install the package via dpkg or rpm, on the condition that all dependencies are met.To make sure that this is the case on Ubuntu, open a terminal window to get a command line, (Applications->Accessories->Terminal) and copy and paste the following line: sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib libportaudio2. Then proceed with the commands below.

I typed:

sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib libportaudio2 

in the terminal and got this:

 Reading package lists... Done
 Building dependency tree 
 Reading state information... Done
 bzip2 is already the newest version.
 libportaudio2 is already the newest version.
 libportaudio2 set to manually installed.
 zlib1g is already the newest version.
 xcalib is already the newest version.
 libglu1-mesa is already the newest version.
 Some packages could not be installed. This may mean that you have
 requested an impossible situation or if you are using the unstable
 distribution that some required packages have not yet been created
 or been moved out of Incoming.
 The following information may help resolve the situation:
 The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.7)
 Recommends: libgl1-mesa-dri (>= 7.2)
 E: Unable to correct problems, you have held broken packages.

What should I do now to fix the problem with libgl1-mesa-glx?

share|improve this question
    
possible duplicate of How do I resolve unmet dependencies? –  Avinash Raj Jan 21 at 10:25
    
Did you ran sudo apt-get update? Include the output of apt-cache policy libgl1-mesa-dri libgl1-mesa-gl. –  Braiam Jan 23 at 14:58
add comment

2 Answers 2

I solved the problem with http://ubuntuforums.org/showthread.php?t=2121036

Someone had the same problem before.

share|improve this answer
add comment
sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libgl1-mesa-dri libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib libportaudio2 -f
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.