Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two NIC configured between two servers one to connect server with internet and other is for fast internal connectivity of the servers each server have three VM's each

i have configured both the NIC on all VM but IP is assign by DHCP on 172.26.43.1 VLAN which is connected to Internet but 10.10.10.1 is IP i am using for private network (only for internal connectivity between all the other VM) with no DHCP so i am assigning static ip

when i assign static IP on VM from here

internet stops working on my VM

configuration on VM is

/etc/network/interfaces
auto eth1
iface eth1 inet static
address 10.10.10.17
netmask 255.255.255.0
gateway 10.10.10.11

10.10.10.11 is the ip of the server on which VM is running

ifconfig
eth0      Link encap:Ethernet  HWaddr 08:00:27:e8:2e:19
          inet addr:172.26.43.88  Bcast:172.26.43.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fee8:2e19/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55831 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1945 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9126338 (9.1 MB)  TX bytes:158629 (158.6 KB)

eth1      Link encap:Ethernet  HWaddr 08:00:27:68:bd:91
          inet addr:10.10.10.17  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe68:bd91/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1184 (1.1 KB)  TX bytes:1184 (1.1 KB)

route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.26.43.1     0.0.0.0         UG    100    0        0 eth0
10.10.10.0      10.10.10.11     255.255.255.0   U     0      0        0 eth1
172.26.43.0     *               255.255.255.0   U     0      0        0 eth0
share|improve this question
    
It worked out when i removed gateway from the static IP i have provided to internal network is there any problem with multiple gateway?. –  Vikas Hardia Feb 3 at 12:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.