Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well, a picture is work 1k words:

enter image description here

Looks bad, huh?

I am using the 331-updates latest 331.67 drivers from NVidia's website on a Dell Latitude e6400. Everything else is up-to-date. This only happens when I resume from sleep, or I switch to a VT and back. It also doesn't ALWAYS happen, which I find odd. Graphics Card: Nvidia Quadro NVS160M

UPDATE AFTER TESTING: This problem only exists with KDE (specifically QT). I can go into Unity or Mint or any non QT-based GUI and it works perfectly with no resume errors.

UPDATE: This only happens when I use KWin (and KDE). I have upgraded to 14.04 and the problem is not occurring as frequently. Also, sometimes this effect doesn't happen, but instead the top menu bar simply goes out of focus with the rest of the screen goes blank.

share|improve this question
2  
Why are you using the latest drivers? And what card do you have? –  Seth Jan 20 at 21:42
    
because 304 gives me terrible problems. –  Whaaaaaat Jan 20 at 22:00
    
Well it doesn't seem like they're the only ones that give you terrible problems :D How do you usually resolve this when it happens? –  Seth Jan 20 at 22:12
    
Reboot. Or restart the KDM service from TTY. –  Whaaaaaat Jan 20 at 22:25
    
Hmm. What graphics card do you have? How many driver options do you have? –  Seth Jan 20 at 22:47

2 Answers 2

up vote 0 down vote accepted

This exact same bug was happening to me recently. Dell XPS M1330 with NVIDIA 8400M GS on Ubuntu Saucy with KDE from kubuntu-ppa/backports.

I found that simply toggling Desktop Effects off and on fixed it. The default key is Alt+Shift+F12. Also, if you leave Desktop Effects off, it doesn't happen. I usually leave them off because it lets my laptop run a little cooler.

Hopefully future upgrades to KDE or the driver will fix this. I haven't upgraded this laptop to Trusty yet.

share|improve this answer
    
Not for me. Someone recommended that in the comments, to no avail. –  Whaaaaaat May 4 at 0:00
1  
I guarantee you that if you turn off Desktop Effects, this will go away. The default hotkey is indeed Alt+Shift+F12. You can also go to System Settings/Desktop Effects and turn off Enable desktop effects at startup. You can also go to the Advanced tab and try changing the Compositing type. If none of the OpenGL choices work, you can set it to XRender and it will run on the CPU instead of the GPU, which should also workaround this bug, but with less performance. If somehow none of that works, edit ~/.kde/share/config/kwinrc and change Enabled under [Compositing] to false. –  blujay May 4 at 1:13
    
It does not. It involves NVidia's dynamic system, which QT doesn't support. It's QT that is causing the problem, not any desktop effects. –  Whaaaaaat May 14 at 21:59
    
What do you mean, "dynamic system"? What do you mean that Qt doesn't support it? KDE and Qt use OpenGL, which is supported by the nvidia driver. There are always some hardware-specific quirks, which is why KWin has its own model-specific blacklist. But what you said doesn't make any sense. If you turn off desktop effects, it will use standard 2D X stuff, not 3D OpenGL stuff, and this bug will not happen. It can't. You can see in your screenshot how it's drawing triangles, obviously in 3D compositing mode. Turn off compositing and this bug cannot happen. –  blujay May 19 at 3:12
    
I tried, still fails with the same bug. –  Whaaaaaat May 28 at 3:44

This for some reason no longer works!

I finally managed to figure it out by following the instructions of a few guides. I'm not sure what part was the magic bullet though.

  1. Run the command nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
  2. Add the content at post bottom to the Device options file in xorg.conf (back up!!)
  3. Run command pm-suspend --quirk-save-pci to test sleep and restore. If it works successfully,
  4. Add pm-suspend --quirk-save-pci to the /var/cache/pm-utils/last_known_working.quirkdb file.
  5. Reboot

Stuff to add to xorg.conf:

Option "PixmapCacheSize" "1000000"
Option "AllowSHMPixmaps" "0"
Option "OnDemandVBlankInterrupts" "True"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.