Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been wrestling with this problem for two days. Since upgrading from 10.10 to 11.04, I can no longer get multichannel (5.1) sound to my speakers. Stereo 2-channel sound was working, but it was using the onboard sound system. I want 5.1 surround sound using my Soundblaster Audigy2 card.

I have now disabled the onboard sound in my PC's BIOS. Now, ALSA is using the Audigy card. Pulse Audio is using the Audigy 5.1 as both source and sink. This is verified by monitoring them in padevchooser when a sound is being played. However, no sound is going to the speakers, which are wired into the three output jacks of the Audigy2 card.

All of this worked just fine on Ubuntu 10.10.

Tim

share|improve this question

2 Answers 2

Try if this helps:

In /etc/pulse/daemon.conf remove the semicolon in the line ; enable-lfe-remixing yes.

If that was not enough try as well:

; default-sample-channels = 2 change to default-sample-channels = 6 (no semicolon and value changed from 2 to six).

Both are a long shot, but trying doesn't hurt.

share|improve this answer

Try editing asoundrc to configure the surround output so that it duplicates the stereo output to all 6 channels, instead of only through the front channel speakers.

Edit this file: gedit .asoundrc

Then add these lines:

pcm.!default {
type plug
slave.pcm "surround51"
slave.channels 6
route_policy duplicate
}

Note: Run the below command, this will list the sound card installed. (If you see others, just remove or disable them).

aplay -l
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.