Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Basically, I've done all of the correct steps in creating the resolution for myself...

$ xrandr --newmode "1824x1036_60.00" a bunch of number -hsync +vsync

(I'm on another computer so I can't copy and paste ^)

It all works fine, but it adds that particular resolution to the table contents "DVI-D-0" when I'm actually using HDMI. So when I attempt to change the resolution via xrandr on my HDMI monitor, it doesn't know what I'm referring to by "1824x1036_60.00". Any help would be appreciated! :)

P.S The resolution is weird because its a weird monitor. It has no native.

fletcher@fletcher-desktop:~$ xrandr -q
Screen 0: minimum 8 x 8, current 1280 x 720, maximum 16384 x 16384
VGA-0 connected (normal left inverted right x axis y axis)
   1024x768       60.0 +
   1360x768       60.0     59.8  
   1152x864       60.0  
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
HDMI-0 connected 1280x720+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
   1280x720       60.0*+   59.9     50.0  
   1920x1080      59.9     50.0     30.0     25.0     24.0     30.0     30.0     25.0  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0     25.0  
   720x480        60.0     59.9     30.0  
DVI-D-0 disconnected (normal left inverted right x axis y axis)
  1808x1036_60.00 (0x2c3)  155.8MHz
        h: width  1808 start 1920 end 2112 total 2416 skew    0 clock   64.5KHz
        v: height 1036 start 1039 end 1049 total 1075           clock   60.0Hz
  1808_1036_60.00 (0x2c4)  155.8MHz
        h: width  1808 start 1920 end 2112 total 2416 skew    0 clock   64.5KHz
        v: height 1036 start 1039 end 1049 total 1075           clock   60.0Hz
  1804_1036_60.00 (0x2c9)  155.8MHz
        h: width  1808 start 1920 end 2112 total 2416 skew    0 clock   64.5KHz
        v: height 1036 start 1039 end 1049 total 1075           clock   60.0Hz
  1920x1200_60.00 (0x2ca)  193.2MHz
        h: width  1920 start 2056 end 2256 total 2592 skew    0 clock   74.6KHz
        v: height 1200 start 1203 end 1209 total 1245           clock   59.9Hz
  1824x1036_60.00 (0x2cb)  156.8MHz
        h: width  1824 start 1936 end 2128 total 2432 skew    0 clock   64.5KHz
        v: height 1036 start 1039 end 1049 total 1075           clock   60.0Hz
  1824x1036_59.00 (0x2d2)  154.0MHz
        h: width  1824 start 1936 end 2128 total 2432 skew    0 clock   63.3KHz
        v: height 1036 start 1039 end 1049 total 1074           clock   59.0Hz
  1824x1036_30.00 (0x2d4)   72.5MHz
        h: width  1824 start 1880 end 2056 total 2288 skew    0 clock   31.7KHz
        v: height 1036 start 1039 end 1049 total 1057           clock   30.0Hz
share|improve this question
    
What is the resolution you want to use? To me this (1824x1036_60.00) sounds like 1824*1046 pixels at 60 Hz. Which is the strangest resolution I've ever seen.. –  Alvar Jan 20 at 11:49
    
I know it's so weird. It's a TV which is functioning as a monitor at the moment, it was made by Dick Smith Electronics. When I first set my pc up with this monitor, no resolution would fit but since I have a NVIDIA graphics card, the NVIDIA Control Panel gives you the option of setting a custom resolution and 1824x1036 was the best. –  user237877 Jan 20 at 11:57
    
^ This was on windows, now I have Ubuntu install alongside Windows 7. –  user237877 Jan 20 at 11:58

2 Answers 2

Use some tool like arandr.

It allows you to define monitor position and resolution graphically (selecting from the modes supported by your monitor), and then it generates a script having a call to xrandr with those settings. You can then do whatever you like with generated command.

Not all monitors will support a custom resolution you create.

share|improve this answer

I was just having this same problem the other day with my LCD TV. It overscans with the default resolution setting. I had to create a custom setting at the native resolution that doesn't seem to get reported with a minimal install (though the resolution is listed under xrandr in the 12.04 live cd).

Anyways, you are on the right track. Getting the custom mode line that works is the hard part. I found a resolution setting that worked in the live cd and then copied the modeline from that. Once you have the modeline you add it to xrandr using the --newmode flag such as you did. Two more commands and you'll be set.

All of the information can be found at:

https://wiki.ubuntu.com/X/Config/Resolution#Setting_xrandr_changes_persistently

First you need to identify the display port that you want to use. Based on your original post, I would guess this to be HDMI-0. You'll also need the name of the mode you are trying to add to the port. The name is the first column of numbers listed under each port in xrandr (i.e. 1024x768 or 1360x768 etc.). If you created the modeline, then it is the part between the quotes in the --newmode command ("1824x1036_60.00" in your case).

Now that you have that information you can add the new mode to the port you want with...

$ xrandr --addmode HDMI-0 1824x1036_60.00

Now you should see that new mode listed in xrandr under the HDMI-0 port.

You can switch to it with this...

$ xrandr --output HDMI-0 --mode 1824x1036_60.00

xrandr settings (including added modes) are lost on shutdown/restart. There are a couple of different ways to make then stick. I put the three commands into a script and have that script called when lightdm starts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.