Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Ubuntu 12.04

After about 5 to 10 minutes of transferring files over rsync, my computer locks up completely. It happens everytime. The syslog repeats the error below dozens of times.

kernel: [33172.840297] phy0 -> rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x308c with error -110.

Some websites suggested to fix the problem by replacing the file /lib/firmware/rt2870.bin with a newer version. I replaced the file, but I continued to get the same errors. The newer version I tried has this md5sum:
36c944c3138125605d28c0a3a1338be9

If it helps, here is the output of lsusb | grep RT

# lsusb | grep RT
Bus 001 Device 003: ID 148f:2573 Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter

Here is the output of lsmod | grep rt

# lsmod | grep rt
xt_multiport           12597  2 
x_tables               29938  5 xt_multiport,iptable_filter,xt_nat,xt_tcpudp,ip_tables
rt73usb                31676  0 
rt2x00usb              20779  1 rt73usb
rt2x00lib              55503  2 rt73usb,rt2x00usb
mac80211              630977  2 rt2x00usb,rt2x00lib
cfg80211              525244  2 rt2x00lib,mac80211
parport_pc             28284  1 
parport                46562  3 ppdev,parport_pc,lp
crc_itu_t              12707  2 rt73usb,firewire_core

I'm trying to stop my computer from locking up from these errors.

share|improve this question
    
I see that the question is quite old and I don't know if I can help, but maybe someone will stumble on this and be saved :) I have a Ralink/Mediatek Nano USB Wi-Fi dongle. Its Linux driver is bugged and won't work on a 64-bit system. At first, after installing the kernel module (driver), everything looks OK. You can even connect to a network. But when any network traffic attempts to move through the Wi-Fi the system gets kernel panic and freezes. I've tried to change th –  butla Apr 25 at 20:45
    
I eventually ended up using a eth cable. If I ever try this again I will install 32bit system. Good thanks. :) –  Rucent88 Apr 26 at 4:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.