Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to open any text file using vi or vim, I get the following error,

vim: error while loading shared libraries: cannot open shared object file: No such file or directory

I compiled and installed tcl 8.6 from source to take care of this dependency but it still doesnt work. What could be the issue?

share|improve this question
up vote 2 down vote accepted

Try this command in a terminal:

sudo apt-get --reinstall install tcl8.5
share|improve this answer
not sduo, sudo! – Danatela Jan 20 '14 at 8:19
@Danatela Right you are, fixed. – minerz029 Jan 20 '14 at 8:26
@minerz There seems to be no package by that name. However I tried installing tcl8.5 but it says that its already the newest version. – JTG Jan 20 '14 at 16:41
@JTG Try the new command. – minerz029 Jan 20 '14 at 21:04
@minerz That gave me E: Invalid operation tcl8.5 – JTG Jan 21 '14 at 16:11

Please install vim using

sudo apt-get install vim

and use

sudo apt-get -f install

if there are any dependency problems.

share|improve this answer
I tried this, but still same error :/ – JTG Jan 20 '14 at 16:40
paste the output of the following command: find / -name "libtcl8.5*" – Jay Jan 20 '14 at 16:46
This gave me a blank output. – JTG Jan 20 '14 at 18:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.