Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here's the deal. I set up a computer with Ubuntu 10.04 for my grandmother. Everything worked fine. I connected it to the internet at her house today. After rebooting the computer I found that the computer would kick you back to the logon screen if you attempted to logon to her account. It worked fine logging on to my admin account, and also in Gnome's safe mode. I thought it had resolved itself, but turns out it hadn't, and now I don't have physical access to the computer, plus the remote connection I'd hoped to use only works intermittently.

I need some suggestions for troubleshooting for when I'm at her house at some point next week. Ask for any more details, but I'm afraid I won't be able to provide many more until I've checked it out in person, since she is basically unable to use a computer beyond web browsing.

Thanks in advance!

share|improve this question

Ideas for debugging:

  • Are there any odd applications in session startup (~/.config/autostart) that may be causing a logout by killing gnome-session prematurely?
  • Check ~/.xsession-errors on the account after it fails to sign in. There should be details of what's going awry.
  • If not, check /var/log/Xorg.0.log to see if X itself is crashing. This is unlikely, as you mentioned that other accounts could sign in fine.

In the meantime, if any of these suggestions don't root up any problems, I'd create her a clean temporary account to use until you're able to resolve the issue.

Edit: This is assuming you have SSH access; it may be a little difficult to relay these instructions over the phone.

share|improve this answer
Thanks, I'll definitely try all of these. I've had a look at logs, but I'm not sure which are pertinent. – MJeffryes Sep 12 '10 at 22:30
up vote 2 down vote accepted

The solution for me was to delete ~/.gconf. Had to reset all of the user appearance settings among other things. No idea how it came to be corrupted.

share|improve this answer
This didn't work for me. – weberc2 Jan 10 '15 at 20:52

Alternative fix:

  1. Switch to terminal screen via: Ctrl+Alt+F1
  2. Login as root
  3. sudo aptitude install gnome-desktop-environment
  4. switch back to Desktop logon screen via: Ctrl+Alt+F8 (in my case)


share|improve this answer
This does not work for me. – weberc2 Jan 10 '15 at 20:52

The suggestion above didn't seem to work for me but I found a thread in the forums that had an answer that worked for me. In my case I would click on the login name and then it would just loop back to the screen.

I tried deleting the ~/.gconf with no luck, or at least doing that alone wasn't enough. To do this, I switched to the terminal from the login screen Ctrl+Alt+F2

rmdir ~/.gconf

The solution seemed to be a forced reinstall of gnome-session, which clearly I must have broke while playing with user or login settings or when I was uninstalling packages I didn't want (Evolution, UbuntuOne).

sudo apt-get install gnome-session

And then rebooted with,

reboot now
share|improve this answer
This didn't work for me. – weberc2 Jan 10 '15 at 20:55

I had the same problem and it was due to an xserver upgrade which stoped recognizing my nvidia drivers, which I had installed manually. Fixed the problem by uninstalling them, and installing them again, but maybe it can be fixed faster by deleting xorg.conf from /etc/X11 and running in the terminal nvidia-xconfig

Hope this helps you, or others with the same problem..

share|improve this answer
This is good info but it's limited to a very specific use case, and it's not clear from the question that this case applies. When you have more reputation points you can use comments to ask the OP to edit the question to include more information. – chaskes Apr 18 '13 at 17:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.