Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had a persistent issue for some time, it is with my sound. When i plug external speakers in i get sound, but the speakers on my laptop dont work...well they do for 20 seconds then they go quiet (20 seconds after rebooting)

My output from aplay -l is:  
List of PLAYBACK Hardware Devices 
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]  
  Subdevices: 1/1  
  Subdevice #0: subdevice #0  
card 1: SB [HDA ATI SB], device 0: CX20585 Analog [CX20585 Analog]  
  Subdevices: 0/1  
  Subdevice #0: subdevice #0  

I have checked in alsamixer if i was muted but it isn't. I cant change any volume ni alsamixer either. I'm thinking its reading the correct card but not the correct device. I have tried hundreds of online solutions but none seem to have worked. I even tried downgrading to 12.04 but i still had the same issue.
According to alsamixer
Card: HD-Audio Generic
Chip: ATI R6xx HDMI
Can anyone help with this long term problem ive had, any help is appreciated

share|improve this question
    
What kind of external speakers? Analog? S/PDIF? HDMI? USB? Are you aware that you have two separate cards? –  CL. Jan 20 at 10:11
    
the external speakers are just some cheap ones and i believe they are analog –  bhawk Jan 20 at 14:36
    
Select the "ATI SB" card in alsamixer. –  CL. Jan 20 at 17:49
    
i tried that but i still have no sound, its been puzzling me non stop for months –  bhawk Jan 20 at 18:26
    
I should also add, while in pavucontrol it shows that the media is playing, but its simply not coming out the inbuilt speakers. The inbuilt speakers are working though as sound works when i first log in for a short time –  bhawk Jan 20 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.