Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I formatted 10.10 and installed 11.04 today. My PC is kind of old so I'm using Ubuntu Classic. First time I booted it worked really nice, with the shortkeys, snap-function and improved workspace switcher. But after installing some software and updates and rebooting, I am being forced to 'No Effects'-mode (without any warning or notice). I have no clue why, and afaik I've installed nothing gnome/appearance-related.

I did try

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

to reset all gnome-settings, but that didn't help.

Does anyone know how to fix this?

share|improve this question
    
I still haven't been able to solve this. I tried repairing Ubuntu by booting with the cd and then choose "Upgrade 11.04 to 11.04". But that didn't help. I'm clueless what to do next. I'm starting to think my pc just can't handle it. It's a Pentium 4 3 Ghz with a GeForce 5700 as a graphics card. –  Bart May 14 '11 at 13:12
    
I found this topic: ubuntuforums.org/showthread.php?t=1750557 , which is exactly my problem. And when I run the command I get the visual effects back. But setting compiz as default with gconf-editor does not work. After rebooting I still get no effects, and the entry in gconf-editer jumped back to gnome-wm. –  Bart May 15 '11 at 9:35
    
Another update: I think it's driver-related. By running /usr/lib/nux/unity_support_test -pI found my videocard is blacklisted, but all other tests are passed. When I check the installed drivers, it says" 'drivers installed but not active'. I tried installing/activating other video-drivers but that didn't do any good either. –  Bart May 16 '11 at 11:09

1 Answer 1

up vote 1 down vote accepted

I fixed it :D

I did it by modifying "/usr/share/gnome-session/sessions/classic-gnome.session". So for future reference:

Before you start, check why Unity/Compiz is not working. You can do this with:

/usr/lib/nux/unity_support_test -p

And:

/usr/lib/nux/unity_support_test -p --compiz

If some tests fail there is probably a better way to fix this (like installing/updating drivers). In my case all tests were passed, but my videocard was blacklisted. When I started Compiz manually (with setsid compiz --replace) it ran fine anyway. I wanted to make it permanent, so I took the following steps:

Safety first, so make a backup of the file:

cd /usr/share/gnome-session/sessions/
sudo cp classic-gnome.session classic-gnome.session.backup

Then edit the file with:

sudo gedit classic-gnome.session

Remove the last 3 lines, being:

IsRunnableHelper=/usr/lib/nux/unity_support_test --compiz
FallbackSessionsID=GNOME2d
GNOME2d=2d-gnome

So the file now only contains:

[GNOME Session]
Name=Classic GNOME
Required=windowmanager;panel;filemanager;
Required-windowmanager=gnome-wm
Required-panel=gnome-panel
Required-filemanager=nautilus
DefaultApps=gnome-settings-daemon;

After saving the file, it boots to Ubuntu Classic, including Effects :D

Source: http://ubuntu4beginners.blogspot.com/2011/05/force-unity-compiz-to-run-natty-narwhal.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.